[SOLVED] Aspect ratio problems in RC3 (black bars)

I think since I’ve upgraded to RC3, I’ve been having problems with black bars at top and bottom when I play 16:9 content.

This can be compensated for in Video > Playback, and that’s what I’ve been doing, but it causes problems when you play 2.39:1 (Theatrical) or 4.3 (SDTV) content.

I’ve set my resolution in System > Video output to 1920x1080i but that doesn’t seem to fix it.

Any ideas?

We haven’t changed anything specifically here.


Not even in the way that Video Calibration works?

For anyone else having this problem I recommend setting up Video Calibration with some 16:9 media playing, especially where you’re asked to make the box perfectly square.

Are you sure the media is precisely 16:9 ?

16:9 is 1.77/1, the majority of movies are actually in 1.85/1 and many older movies are in 2.35/1. This means that on a correctly adjusted TV it’s normal to see thin black bars at the top and bottom of 1.85/1 movies and for 2.35/1 you will see quite large black bars at the top and bottom.

I don’t suppose you use overscan settings in config.txt ? If so check this post by popcornmix about recent firmware changes:

In all likelyhood you had enough overscan/zoom before to crop the sides off 1.85/1 and/or 2.35/1 material so that you didn’t see bars at the top and bottom.

The video that finally put me over the edge into fixing the problem was 4:3, I was using the setting to eliminate black bars and it worked great with 16:9.

The video I used when fixing was 720x404 ( 720 / 404 = 1.782178218 ). So I’d say it qualified as 16:9. Just to be safe I made sure the [fix black bars] option was turned off and adjusted the box’s shape while playing a 1920x1080 video.

When I adjusted the shape of the box in video calibration, it changed the shape of the video, eliminating the black bars when adjusted properly.

osmc@osmc:/$ cat /boot/config.txt 

Is there a problem with my config.txt? I haven’t changed anything except for max_usb_current. Should I be making overscan changes there instead?

It should be noted that I’m using a fairly old Rear Projection HDTV. As far as I know there’s no way to change overscan settings on the tv.