[SOLVED] Buffering on portion of files


I have been running Pi 3B+ for years now. Couple of days ago I upgraded my network to all high end Ubiquiti stuff. I did a fresh install of OSMC (etched the image with balena Etcher and restored a backup of my settings. I have always used same NAS for storage, without issues. Due to new IP, I added the NFS share as a new source and refreshed the library. So far, movies seem to work fine (I watched two in the meantime). However, newly added series (for example Love & Anarchy, x264, AC3, +/- 2.5 GB per episode or Lupin, x264, AC3) are not watchable. It takes about 30 seconds to start (never happened before) and it is constantly buffering, with audio out of sync.

Pi is wired with ethernet and my speedtest-cli showed 86 Mbit/s down and 40 Mbit/s up. I realize the NAS is not outside my network, but the throughput speed is there.

What shall I do to look into this problem and hopefully fix it?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Sorry, forgot to reboot twice.


I started first episode of Love & Anarchy. It took 15-20 seconds to start, stuttering, buffering, audio out of sync, let it run for a bit and then buffering again. I stopped.

I started Julie & Julia (movie from exact same NAS, different folder). It started immediately without delay, not buffering, I skipped ahead twice to test. I stopped.

EDIT: I downloaded different release of Love & Anarchy and got the same. I have maybe 20 (older and previously downloaded) series on the NAS and every single episode I start runs perfect. What is happening with these two series, that break the player? Codec seems the same to me.

can you transfer that episode of Love & Anarchy to USB storage and try to play it locally and see what happens?

Good idea and guess what, it runs flawlessly… how is that possible? Other series on the exact same parent directory run without issues…

I’m not sure. I would be looking at running iperf between you NAS and RPi though instead of between the RPi and the interwebs. Maybe also on both a problem file and one that works bring up the information window, highlight the “refresh” option and take a look at the file path being used. Are they both using either a machine name or ip address, or is that different between the files.

Again, good suggestions and thank you for the tip. I installed iperf3 on the Pi and NAS and these are the results. Looks pretty solid and fast to me!

I also checked the paths and they are built up the same. NFS, IP address, same Shared Folder.

I hesitate to ask… but… any other ideas?

Nothing is coming to mind. You might try a system mount or running a test with SMB instead of NFS but why one video would have issues playing over the same ‘everything’ vs another without their being a file size component being involved is rather curious.

That 30 seconds to start is also rather odd. You didn’t happen to introduce a network loop when you setup your new network did you? Maybe some device is manually set static and is conflicting with another device because you didn’t reserve it in the controller? Does you NAS have dual ethernet and you plugged them both in without aggregating the ports on the switch?

Will try SMB later tonight.

There are no conflicting IP’s on the network and I also do not have a second ethernet cable plugged in the NAS.

It’s super weird that virtually ANY other series or movie runs good. But I now have two (recently downloaded) series (Love & Anarchy and Lupin) that are showing same issues. I’m currently downloading another freshly aired series to test.

One thing I investigated just now were permissions. But the folders of these series show same own, group and permissions compared to working series.

I even copied the Love & Anarchy file to the Movies folder on my NAS and tried to open it using the File Explorer: same problem.

Since it plays without issue from USB storage it is exceedingly unlikely to be a file issue.

I agree, that makes it so weird.

First, your iperf3 test is for the speed to the NAS. You really need to be testing the speed from the NAS, so add the -R flag to the command.

Second, the IP address of your Pi is, while the IP address of the NAS is What’s the story here, other than you have a bunch of “high end Ubiquiti stuff”?

Looking at the logs I would suggest it’s the file format of Love & Anarchy rather than network issues.

For Love & Anarchy file, Kodi is detecting a different (wrong?) demuxer in the file format and ffmpeg is choking on it. Suggest trying a different version of this movie.

Compare the lines starting “Open - probing detected…”

2021-01-11 11:00:48.144 T:1916190736   DEBUG: CVideoGUIInfo::InitCurrentItem(nfs:// & Anarchy/Season 1/Love & Anarchy - S01E01 - How It All Began.mkv)
2021-01-11 11:00:48.144 T:1916190736   DEBUG: CPlayerGUIInfo::InitCurrentItem(nfs:// & Anarchy/Season 1/Love & Anarchy - S01E01 - How It All Began.mkv)
2021-01-11 11:00:48.159 T:1457492192   DEBUG: NFS: Connected to server and export /volume1/Movies
2021-01-11 11:00:48.159 T:1457492192   DEBUG: NFS: chunks: r/w 131072/131072
2021-01-11 11:00:48.179 T:1457492192   DEBUG: ScanForExternalSubtitles: END (total time: 43 ms)
2021-01-11 11:00:48.180 T:1457492192  NOTICE: Creating Demuxer
2021-01-11 11:00:48.185 T:1457492192   DEBUG: Open - probing detected format [mov,mp4,m4a,3gp,3g2,mj2]
2021-01-11 11:00:48.655 T:1457492192   DEBUG: ffmpeg[56DF90E0]: [mov,mp4,m4a,3gp,3g2,mj2] stream 0, timescale not set
2021-01-11 11:00:48.655 T:1457492192    INFO: ffmpeg[56DF90E0]: [mov,mp4,m4a,3gp,3g2,mj2] Protocol name not provided, cannot determine if input is local or a network protocol, buffers and access patterns cannot be configured optimally without knowing the protocol
2021-01-11 11:00:59.858 T:1457492192   DEBUG: Open - avformat_find_stream_info starting


2021-01-11 11:02:31.984 T:1916190736   DEBUG: CVideoGUIInfo::InitCurrentItem(nfs:// & Julia (2009)/Julie & Julia (2009).mkv)
2021-01-11 11:02:31.984 T:1916190736   DEBUG: CPlayerGUIInfo::InitCurrentItem(nfs:// & Julia (2009)/Julie & Julia (2009).mkv)
2021-01-11 11:02:31.999 T:1474277600   DEBUG: ScanForExternalSubtitles: END (total time: 24 ms)
2021-01-11 11:02:32.000 T:1474277600  NOTICE: Creating Demuxer
2021-01-11 11:02:32.006 T:1474277600   DEBUG: Open - probing detected format [matroska,webm]
2021-01-11 11:02:32.012 T:1474277600   DEBUG: Open - avformat_find_stream_info starting

A better test would be Love & Anarchy over the network, versus it being played from local storage.

Interesting, will try the -R flag to the command!

EDIT: same speeds

I run different vlans, to group and block certain devices. Although I see the relevance of that, I don’t see why being on a diferent subnet will work for 99% of the files and not for 1%.

Seems you were right, djbloc. Although I did try a different release of the episode, with same issues, I went to a different indexer and specifically picked an older and bigger release. Runs smooth. Tried the same with Lupin (series that was giving me same issues) and downloaded a more recent release (again significantly bigger, about 3-4 times) through different indexer and plays without issues.

Thanks for all the help guys, learned something and solved something. Still not sure why it would play locally without issues though, but I’m okay with not knowing for now… :grimacing:

I would still be interested to know if the issue was also present played through a Kodi SMB path and through a NFS system mount.

Neither do I but (1) you didn’t mention that you were using VLANs; (2) understanding the network configuration can sometimes help with diagnosing a problem; and (3) the problem started when:

You say you’d been running without problems “for years”, so, by my reckoning, it would be a very unusual coincidence if a problem that is unrelated to the network upgrade were to occur at exactly the same time. Hence the question.