[SOLVED] Error 2 Share Not Available

Hi there

Some time ago, I was getting this error and it was solved by using passwords.xml.([SOLVED] Error 2 Share not available)

I had to rebuild my pi today and, even with passwords.xml being there…I can’t add sources to enable scanning of my storage (windows pc). I get the Error 2 Share not available message.

Obviously, the thought of a complete library rebuild is not at all appealing. I use a MySQL setup, so all of my library is already configured to access \server\share\tv + \server\share\movies (9 hard drives, TV Shows and Movies for each), so 18 sources that I need to scan for changes.

I checked the MySQL and it definitely stores the SMB with server name, not IP…

My question is, can I manually create this? With sources.xml or another file? That would allow me to specify each TV Show and Movie share? Or, is there a way to get SMB browsable again? I realise that SMB is unreliable, but this installation has been running for a very long time and I don’t really want to rescan 25000 episodes, 4000 movies and 95000 mp3s…


1 Like

And in true style, I figured out a solution.

I added a network location, specifying the server name but no shares - Specified my login information and saved it.

That gave me an additional option in the Browse for Location of smb://server

This worked perfectly and let me setup the TV shows and Movie sources as I had previously done with the Windows Network (SMB) option.

I did a library scan and no duplicates…so that seems to be a solution. Not sure what is causing the failure when browsing the SMB network, but using SMB directly to a server name works perfectly.

I posted my solution as I figured it might help others.

THANK YOU! Finally I can access my shared folders through my Raspberry Pi 2!