[SOLVED] ERROR: failed to load requested skin 'skin.osmc'


Just moved across to the OSMC RC from Raspbmc on my Raspberry Pi B+. Everything looks very promising (I got hyperion and transmission set up pretty quickly).

However after going through settings in the UI and configuring things I rebooted the system and was greeted by a sad face (does that thing have a name? Much better than ‘relax’!).

The last three lines of my kodi.log are errors:

18:27:22 T:3024687104   ERROR: failed to load requested skin 'skin.osmc'
18:27:22 T:3024687104   ERROR: Previous line repeats 1 times.
18:27:22 T:3024687104   ERROR: Default skin 'skin.osmc' not found! Terminating..

I’ve tried deleting the guisettings.xml, the userdata folder, and the entire .kodi folder, but these attempts haven’t resolved it.

Here’s my full logfile: http://paste.osmc.io/epewonumit.coffee

Thanks very much for your help. After initially being nervous about trying it, I think OSMC is looking great!

Did you actually re-install with the fresh RC image?

EDIT: Ok sorry, just re-read as I didn’t realize you were coming from Raspbmc.

From Raspbmc, or…?

It was a completely fresh install.

Right, I’ve tried going into rescue mode and I’m getting “Segmentation fault”.

I actually moved from raspbmc today because I was getting similar errors on that setup.

Could it be my USB (where I install these things) that is borked/corrupted?

That would be my first guess if the issue has persisted across OS’s.

Right, running for over 24 hours now on a new USB with no further issues. Seems like we found the culprit! Thanks for your help.