[SOLVED] Install failed: could not mount bootfs (RPi2)

When I start up I get a few lines about missing device nodes for CPU. Then once the OSMC screen comes up it shows 0% then a bit later “install failed: could not mount bootfs”.

I’m using a 16gb micro SD card.

Any ideas?

Device node issue is not relevant.

Need to know more:

  • How are you installing the image? Did you use the official installer?
  • Are you installing to a USB or NFS share?

Hi,

I have the same problem. To answer your questions,

  • I used the official installer, for Mac OSX ( OSX 10.10.1 )
  • I installer it to my micro sd through my SD port on my macbook air

Hope I had been of assistance.

My micro SD card is a 32gb Transcend, for the new Pi 2.
Had Transcend SD with all my Pi’s before, never had a problem.

Solved it by formatting the card instead of just reinstalling :smile:

Worked. Thanks very much :slight_smile:

I have the same issue and have been at this for hours now. I reformatted my 16GB micro SD card. I installed using official OSMC for Mac. I inserted SD card into raspberry pi2 and I get Install Failed, could not mount bootfs. This is my first raspberry pi project and I’m ready to throw it off the balcony. Any detailed instructions would be much appreciated. thank you.

Try selecting Rpi1 in the installer before writing the card please.

OK, I will try. thank you.

That did less than the other. Yellow light flashed once, and I’m left with pretty multicolored screen and that’s all it does.
Here’s what I did:
I have QT_host_installer, I inserted micro SD 16GB into Mac, formatted disk, saw that it had nothing on it.
Clicked on Qt_host_installer. It asked me Vero, RP1 or RP2, I chose RP1, it asked me RC1 or RC2, I chose RC1 (I don’t know what these are), anyway, connected to my wireless, it grabbed files, asked me for password so it could do something, I gave it, it did stuff and then said quit. I checked SD card and it has:
bootcode.bin
cmdline.txt
config.txt
filesystem.tar.xz
fixup_cd.dat
kernel.img
preseed.cfg
start_cd.elf
I removed micro card from it’s adapter, inserted into Raspberry pi, which has wireless, keyboard, mouse in USB ports.
I turned on the power and result is nothing but pretty colored screen.
Can you tell me what I’m doing wrong please?

Ok, my suggestion was because there have been a LARGE number of users who think they have an Rpi2 when they actually have a B+(Rpi1). You should always choose the newest RC for install (Release Candidate 2). If attempting to install for Rpi2 with RC2 results in the same problem, the problem is likely the SDcard itself. The Pi2 has been picky about some cards. At that point I would suggest trying another card.

I just bought the SD card today. :frowning: $40

I don’t know what you bought, and from whom, but that seems excessive
Derek

This means that the wrong version has been selected. You should select ‘Raspberry Pi 2’ and see if this fixes the issue

Sam

Hi Sam, I put the original SD card that came with the RP2 into the adapter and installed onto it. I put the SD card into the RP2 and powered up. I got farther this time, but when I selected I’d like to set up networking manually, it’s just stalled. Any suggestions?

Why didn’t you set up networking manually from the sdcard installer?!

I have my network set up now. It says connected. I have a menu that says Videos, Music, Pictures, My OSMC, Favorites…nothing like the screen shots I see of latest movies or tv shows. How do I get those please?

http://kodi.wiki/view/Adding_video_sources

Thank you all for your help. I’ve packaged the RP2 back in its box and I’ll be returning it. This is too difficult for me.

Go to raspberrypi.org/downloads. Downloads NOOBS and use that to set up OSMC.

S

Thanks Sam, but I’ve boxed it up. It would have been nice if I could stream movies or tv but this is just too difficult.