[solved] Issue with sshfs since last update


First sorry for my English, it’s not my mother tongue. I use osmc on a raspberry B, and before osmc I used raspbmc. My video is on a distant server, and I use sshfs to play them. Yesterday I updated osmc, and since it, when I play a video, it launch good, I see the buffer raise up () and after one or two minutes, the buffer stop to fill and the playback is stopping when the buffer is empty. In Kodie.log I found this warning :
21:11:52 2970.411133 T:2803364896 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

I connect with ssh on raspberry, and I execute a ls command in my directory used with sshfs. I have a response, but if I re execute many times the ls, sometime I have a response as sshfs was not connected (sorry I don’t notice the exact message).

And I try to display some local video, on a USB disk, and I have no issue.

Someone has an idea?



I do some other test, and I’m not sure my issue is linked to sshfs. I have setted a https source with my server in Kodie, and I have dame issue : after a few second, less than one minute, the size of data in the buffer doesn’t increase. And the video stop when the buffer is empty, so I can watch only one or two minutes of my video.

Is Someone has an idea please?
Thanks in advance

What do you mean by a “distant server” do you mean you are trying to stream across the internet ?

If so the obvious conclusion is that there is a speed or reliability issue with the network connection to the remote server. If the data does not come in fast enough to stream the buffer will empty and playback will stop.

Hi dbmandrake,

Thanks for your response. Yes I do some streaming across Internet. I was thinking like you, that i have some issue with my Internet connection. But it’s not the case, I have checked with my Internet supply.
When the buffer decrease, I try to make a ls in the sshfs directory, and I have a error : cannot access transport endpoint is not connected. But if I try in the same time to access to my remote server with sftp on my laptop, it works. And after a while, about 30 seconds, the sshfs is reconnected again, but the video playback doesn’t resume.
So maybe I have some disruption on my Internet connection, but it should be disable for a very short time. But if the sshfs is reconnected well (checked with the ls in sshfs directory), the media player is not able to fill the buffer again.

And for information, I have this option in my fstab :
port=1337,user,noatime,allow_other,uid=1000,gid=1000,x-systemd.automount,no auto.
Maybe one of this option is no more supported by osmc?

I have set up a new source in Kodie using sftp for the same server, and I have the same issue. After a while, the playback stop. I have try with Kodie for Android just after, set up same sftp source, and no issue, I could watch entirely my video. So I think I have no issue with my Internet connection but with osmc.

Is the Pi wired or wireless? Is the connection on the Pi dropping out? Possibly a power supply problem


My pi is wired. I’m not sure how to test my Internet connection on my pi, but I launch this command on it :
Ping www.google.fr
And playback my video. I saw a few second where the ping doesn’t give me response, and in the same time the buffer doesn’t fill up. But I call hotline of my Internet provider, and they told me they doesn’t see any deconnexion. And I didn’t change the pi power supply. It’s a hub usb that I have bought in the same time that the pi, and I never had some issue.
Do you think if I change in advancesetting.xml the cachemembuffersize to another thing that 0, the buffer should fill up the buffer, and when is empty re fill up again. And if I’m lucky, at this moment my Internet connection could be active?


Finally you had right from the beginning dbmandrake, I have an issue with my Internet connection. I had someone qualified at my Internet provider hotline who find and resolve it.

This thread can be marked as resolved! Thanks for your help!

I believe you can go to your first post, edit the title to show it is solved.