[SOLVED] July update broke config.txt editor addon

I updated 2 rpi2 to rc2 and config.txt editor is broken on both of them.

Then i made a new installation and it is broken there also.

Is there anything i can do to fix it?

Step 1: Define “broken”
Step 2: Turn on debugging
Step 3: Replicate the error
Step 4: Upload the log files using the Log Uploader module
Step 5: Post the resulting URL.

Step 1: Define “broken”
When i try to start the editor from osmc addon → Pi Config-> Config Editor → Open Config.txt Editor i get the message
Addon error. Check the log for more information

Step 2: Turn on debugging
Just did that.
I did not choose specific loggin. I am loggin everything. If i should not log everything please advice.

Step 3: Replicate the error
I guess you mean after enable debug try to open the editor and see the error. Done

Step 4: Upload the log files using the Log Uploader module
I uploaded everything. If i should not do that please advice what i should upload.

Step 5: Post the resulting URL.

Thank you in advance my friend.

Thanks for that. Its an odd issue that hasnt come up before. There will be a fix in the next release.

But lets try something a little experimental: this should download the fixed file for you, overwrite the broken one, and then upload a log of its success or failure.

Go to the Updates module in MyOSMC, down to Manual Controls, choose Apply Hotfix, and enter this code:


(Note to readers: if this does work, it will only be applicable to the current version. Anyone who runs it after the next update can’t complain if they have a bad time.)

i did exactly as you advised and wrote the word gipotohiqo in the apply hotfixes, got the warning about applying hotfixes only from people you trust and such pressed ok and thats all.

I get no info after that that the hotfix has been or not installed.

I will also try a reboot and see.

Thank you

i also did try to restart after that but nada. In my eyes its like applying hotfixes does not work either. Or that is the case and after you press the ok in the warning you see nothing else?

Also when i press on the apply hotfix you get the windows where i have to write down the word of it. There i have a predifined one, an already writen one named lanevudaqu

That stands for both my old and updated to july 2015 installation and on my new installation.
The apply hot fix has the same results on both of them.

The details will be in the Log in any case, so if you provide that again we can see what happened.

i will run it again with debug on and post the url. one second pls.

Log url

OK, I think this code will do it: ayereveriy


oh yes that did the trick.

By the way really thanks for the help.

Now on the system i applied the hotfix will there be any problem on the long run after future updates?

also do you need any logs after the hotfix applied? maybe after i open the config.txt editor?

also can i apply the same hot fix in my other newly installed system?

and damn but how do i define this topic as solved?
:smiley: Found it.

If the hotfix worked, then I dont need any other log files for the issue, but if you could provide them it would help understanding why the HotFix results didnt upload.

There will be no problems with future updates; the file you fixed will be overwritten with the newer version on next update.

You can use the fix on all other installs with this problem. And that applies to anyone else who reads this thread who has the July 2015 version of OSMC or earlier. (Anything after that and the fix will revert the already fixed file.)

Thanks for the log files and feedback, this thread is one of the best for user-responsiveness and helpfullness.

1 Like

log url after hotfix applied and problem fixed


once again really thank you my friend.

after a lot of problems and unstability with one of my upgrades from june version to july (subtitles addons did not read the subtitle language download for, in settings and where showing all languages), if you did try to get the list of subtitles for a movie all the way down you get to the sad face and kodi restart, kodi restarts in varius situations, 2 or 3 times after the sad face most of my settings where back to default.

So i guess a new installation from scratch would be a good idea.
1st of all the new update is not an option from the windows installer. So all you get is june version and then you can update from within kodi after the true install to july version.

2ond the thing with the config.txt editor is again there. But now the hotfix does not work anymore. maybe the hotfix code does not stand anymore? i do not know.

Any solutions?

THanks in advance.

Here is a replacement HotFix code: osekejusep

Maybe look at using the backup function in the Updates module to backup your userdata and settings info to a network location, or attached storage.

i have a backup but its from the installation that problems appear and i wanted to start clean, with no addons or anything else and go step by step.

Really thanks my friend.

That hotfix code did the job. Thanks once more.
I guess you do not need any logs or anything.