[Solved] Mouse Irratic and not Wifi on new install

I Have a new Raspberry Pi 2B and a fresh install of OSMC on the SD Card from this website which I installed with a MAC.

I have input the Wifi details at install but it appears its not connected

Also using the mouse, it keeps stopping/stalling and when clicking on menu items is often unresponsive.

Any ideas on what I can do to improve this?

Have you switched to a different skin ? The default OSMC skin does not support mouse control.

For wifi - have you tried going into OSMC settings->Networking and configuring your Wifi there ?

No I haven’t changed the skin, so that would explain why it was a little erratic.

I have found that the TV remote seems better, although it seems to loose the HDMI-CEC connection. I have to go back into the TV settings and reselect it.

I will have a look in the OSMC Settings section shortly - Is that the screen with the pictoral menu, Globe at the top and Network type graphic at the bottom?

Ive reinstalled but have gone for the RC version this time.

In Network settings, my network can be seen, but despite multiple attempts at entering the password, I get a Failed error message

Debug logs?

Ive managed to get wifi working by adding the netwok in the command line.