[SOLVED] Newbie Help OSMC not booting

I am fairly new to the raspberry world and I was trying to install osmc on my raspberry b+. Everything seems to go fine installing on the sd card but then when I put the sc card in raspberry, it doesn’t boot further than the colored square.

What am I doing wrong? Pretty sure it is newbie error…

I know everything works as I am able to start with Noobs and I also tried to install openelec which worked as well.

Thank you for the help

The first question is have you chosen the right Image? Which Raspberry Model do you have and which Image have you chosen?
Second check what does the SD card say when you insert it into your PC? Does it show one 240M VFAT partition with the files needed for booting?

also with what software did you create the image on the SD card?

I used the OSMC installer and picked the RC2 for the Rapsberry Pi 2 (I have rapsberry pi b+). So I didn’t use an image per say but rather had the installer download and install it
When I insert the SD card I would need to verify the partition but if I remember correctly, (I am not at the location right now), it shows maybe a dozen files which seemed to be the ones I saw online from other people. Now is that a partition, I am not sure.

thank you for trying to help!


The Raspberry PI B+ is one of the original models and requires the Raspberry Pi image not the Pi 2 one

ok. I will try again but I think I tried both. when the first one was not working, I think I tried to install the other one. although I may be confused between RC1 and RC2 (it was late last night :slight_smile:

I will try again! thanks!

when you have RPi 1 (RPi B+) then use image for RPi1 RC2, here is the direct link :smile:

Thanks all. Indeed I had chosen the wrong rpi image… Newbie mistake :stuck_out_tongue_closed_eyes:

Please add [SOLVED] to title

Hi, had something similar while installing on the Pi 1.
I tried to run the installer from within the RAR (did not unrar first)
The device would not boot.
Tried it a 2nd time, same behavior.
On the 3rd attempt (before loading an earlier version of raspbmc), I first unrar’red (!) the downloaded file, and that time it worked great.
Hope this is useful for someone…