[SOLVED] Odd Playback Problem

I’m not too sure what is relevant to this problem so apologies if I go overboard providing information.

I’m running Emby as a directplay backend server on CentOS7 with a 1GB ethernet link to a Gigabit network switch. I have two Raspberry Pi 3s running the latest level of osmc (but had the same problem on previous versions) and 2.3.46 of Emby for Kodi. One is wired into the switch the other is WiFi.

I have TVs/Movies (SD), captured analog camcorder footage and later HD digital camcorder footage that all plays fine on this setup.

I have further footage from an SD digital camcorder that I am having problems with. I have tried using it as ‘.dv’ or transcoded to ‘.mpg’ without any obvious difference.

When I play it on either Pi the sound starts before the video but is kind of crackly, sometimes the video doesn’t start at all but if it does it is jumpy. The sound either stops or progresses to a kind of 100 beats/min drum effect before stopping. The onscreen display switches between a predicted ‘end of playback’ time or ‘buffering…’. Sometimes, but not always, there is a message about the source being too slow for continuous playback. That seems unlikely since all of the other media works fine.

However the same media plays fine on the web interface for Emby on a PC, and Emby apps on android phone or iPad; again this looks like the source is plenty fast enough.

Emby support says because it is using DirectPlay they can’t really see any useful diagnostic information. So, I’m hoping that you may be able to give me some idea what the issue is; a media issue, a Pi or OSMC problem?

I’m not sure what further information would be helpful but I can drop an example copy of the media on a shared service if that would help.


Sorry, I’m new here and I just realised that there are sub-categories for Help and Support. Can an admin move this to ‘Raspberry Pi’ or would you rather I repost it there?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload some logs. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

It would also be very helpful if we could find out more about one of the files you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC

Sorry, I’ve been meaning to update this but constantly got delayed. I was starting up doing a proper bug report as you suggested and then realised what the issue (probably) was.

The files I was having problems with had been captured as mpg files and I had assumed that they were mpeg-4. It turns out that they were Mpeg-2 and so very large (for their content) and requiring lots of bandwidth. I presume they worked alright on the other devices because Emby was automatically transcoding them for the lower resolutions devices.

So I transcoded these as mpeg-4 and the problems went away.

Sorry again it tool so long to update. Any further issues I will start with a proper report.

Did the inexpensive mpeg2 codec not handle?