[SOLVED] OSMC A4 Pi2 stream to Android issue

Hi there,
I am using alpha 4 on my pi2 and I was trying to stream from the pi2 to my android device (tablet +phone) using the buy version of Yatse (xbmc remote app).
However, there seems to be a problem if I try to access video content on an external usb drive. Thus, the stream never even starts.

If I access a video file on the SD storage of the pi, it magically does the trick…

Is anyone else experiencing the same issue? + Are there any suggestions for a possible fix?

Is the file you are trying to stream in your library already? Movies or TVShows?

Yes the file(s) are already in my library. I did only test this with a movie so far.
(TV shows also won’t stream, but I did not transfer them to SD-Card to test whether they work from there)

I solved it! This is SO sad…
Solution Link

Solution by Tolriq:

When having problems with Yatse you should contact me :-)

Anyway this is a known problem / limitation / feature of RPI (choose what you prefer :-P )

rPi allow scraping and adding to database media that are not in a source with some default path, and this is bad for remotes since they do not have access after that.

You just need to add a source to /var/media with no content and no need to scrape, this will just allow remotes to access this path.

Maybe one day someone will fix this because it's number 1 support problem ;-)

First I’ve ever heard of this problem.

Better late than never :blush:
However I am pretty confused that no one else seems to have problems with that…

Maybe no one but me wants to watch movies while working out on a treadmill :smile:

Any chance that “/var/media” is added as source by default?

We’ll look at adding this as a hidden source so you this gets solved



1 Like

I hope this saves a lot of (googling/forum-search) time for many other OSMC-Pi users!