[Solved] Osmc not updating to rc2

I have been trying to update to rc2 through manually updating osmc expecting to get a message saying it is already up to date however it keeps attempting to update . If i look through the files and what not i am pretty sure i am on kodi version 14.1 where rc2 should be 14.2

Now it is very possible i am doing something horribly wrong and/or my osmc is secretly up to date but just in case ive uploaded all osmc logs here: http://paste.osmc.io/usoqukepel

Any guru out there that could tell me whats wrong?

Are you trying to upgrade from Alpha 4?

How do I check that? :x its from the preinstalled version on my vero.

Vero shipped with RC1 or later.

Will check log shortly

S

Anyone have any idea yet? Or will I simply have to reinstall from scratch :frowning:

The last successful attempt at running an update that is listed in the logs is the 6th of April - however on the 19th of May I can see the OSMC settings updater tried to run but apparently didn’t succeed.

When you choose the manual update option do you get any sort of error message coming up ? Are you waiting a few minutes ? You definitely have a working internet connection on the Vero ?

If you can open an SSH connection to the Vero issue the following command to manually kick off an update:

sudo apt-get update && sudo apt-get dist-upgrade

Don’t panic when you see the screen go blank part way through - it will do this when it gets to the point of upgrading Kodi itself. (You can’t upgrade Kodi while Kodi is still running) It could take a good 10-15 minutes too, so be patient as you have a couple of months worth of updates to download.

Assuming it finishes without errors, simply type reboot when finished and you should be up to date. If you get errors, please copy and paste them here.

If you can’t connect with SSH you could plug in a keyboard and run the above command from the local console - see how to log in at the local console here:

https://osmc.tv/help/wiki/console

Executing the command now, when I do it manually I do not get any errors or anything, it kept showing the same files it needed to download though and around 21/27 it would then ‘stop’ for some reason.

I can confirm it has internet btw, as I stream through Genesis sometimes as well as the fact I can see it download in Putty now after executing the command you mentioned :smile:

The command did the trick, 57 upgrades, and something like 5 new installed.

Second time I run the command it tells me nothing to install or upgrade so I suspect it’s up to date now.

I’ll keep a link to this thread at least in order to be able to execute this command again in the future should it be needed. Hopefully what ever it was will be fixed in one of the many updates in the meantime.

Yes if it says you have no updates on the second attempt then you are up to date.

FYI, now that you are on RC3 we have added a cool new feature, see the manual update check:

https://osmc.tv/help/wiki/console

Basically if you hold down SHIFT and CTRL while booting it will automatically check for and install updates during boot - basically achieving the same thing you did manually but with the blue update screen.

The idea behind this is if your Kodi install gets a bit messed up or the OSMC settings updater doesn’t seem to want to work for some reason it provides an easy way to upgrade yourself out of trouble without messing around with manual commands. (Assuming that an update addresses the problem you were having)

Yes almost certainly fixed already. The were a lot of bugs in the old versions of the OSMC settings updater that have now been ironed out.

I’m happy I saved the bookmark… had the same problem again now when trying to update out of RC 3 v 0.9.9.

Command works though so I’ll do it that way… Not a huge problem I guess just odd :slight_smile:

Can you post your debug logs so we can see why it failed ?

http://paste.osmc.io/lixurimune

There you go. If its something idiotic on my end feel free to use harsh words.