Hello all! I recently found an old 1GB SD card, and I challenged myself to put a functional OSMC install on this little thing. I have also bigger (8 GB) card ready, but I would like (just for fun) make some modification to the partition layout and have some more space on / partition.

So, after a fresh install I have roughly a 255 MB /boot partition and 750 MB /. /boot has only 25 MB on it, while / after (apt-get update and installing YouTube and Jupiter Broadcasting leaves me with only 12 MB of free space. Not really much, since I would like to install some additional stuff (rsync, tmux, maybe some other stuff) and expect log files to grow after some time. So I figured, that I could shrink the /boot partition to 75 MB (space for 3 kernel images) and expand the /, which would give me at least 150 MB extra space. More than enough for me. So, I dd’ed the CD card to have an image backup, rsynced /boot and / to separate directories, created new partition scheme with fdisk, created filesystems (vfat for /boot, ext4 for /) and copied over the contents of each directory separately. Since the /boot partition didn’t have the bootable flag set, I didn’t change that either. I put it back to Raspberry, but no success.

Then, I tried two different things - i dd’ed the 447 bits from the original backup image to the SD (that is where the boot code should reside, right?), so I had boot code + new partition layout. No success. Then, I tried to install GRUB via grub-install form my Xubuntu laptop, but still no success.

I have the backed up image that is ready for action, but just out of curiosity I have a question - what am I doing wrong? Does OSMC doesn’t use GRUB?

Thanks for taking the time to read that longish post.I would appreciate any of your suggestions.

Grub is for x68/64.
Arm socs typically use something else. The raspberry is booted by the gpu iirc and others use bootloaders like uboot.

See here for more info:

You’re thinking of U-Boot SPL.

You just need a vfat partition with those contents.

But 1GB is really tight. I think that a 1GB SD card won’t have good performance, as it will be quite old. SD cards are cheap – if you can, just grab a bigger one.


Thanks for the info guys, your posts made me realized the problem lies elsewhere. Actualy, mkfs.vfat from Xubuntu creates FAT16 instead of FAT32 (gparted told me so). When I created proper FAT32 partition everything works (and I have 182 MB of free space on root, yay :)).


That 182MB of free space won’t do you much good. The first time you try to scan a library you will run out of space and Kodi will start crashing on boot because it can’t create its log file.

You also won’t be able to install any OSMC updates as the updater checks for at least 300MB of free space before proceeding. (For good reason)

So I’m not sure what the purpose of the exercise was when a much larger SD card that will almost certainly also be an order of magnitude faster can be had for the cost of a couple of cups of coffee…