[Solved] Problems with Update of Video Library

When I run an update of the video library I get messages in the log telling me that some files/directories are not found. I don’t have a problem with that because they are not there and are not supposed to be there. How do I get rid of these messages? They will not go away with a “clean” and I have completely rebuilt the videos and tv files by removing the sources and adding them again.

So you mean Settings - Media - Library - Clean Library hasn’t solved the missing file message?

I believe this is normal and expected behavior. I don’t think the clean library function bothers removing old source folders, just missing files. I think the only way to remove these outside of deleting your library db and scraping again would be to manually edit the database. I think there might be a way to do it with the Texture Cache Maintenance utility as well but I’ve not tried to do that one myself.

Yes exactly what I mean.

More problems with the update and clean process.
Please see the log at paste.osmc.tv

P.S. The URL on the FAQ is incorrect it points to paste.osmc.io

Which FAQ? Can you provide a specific link so we can edit?



Allow us to help you

It goes without saying that the better we can understand a problem you might be having, the more likely we can help you fix it. When you make a post, you may be asked to provide a log. You can read more about obtaining logs on our wiki here

These are best uploaded to a Pastebin website. We recommend you use our official Pastebin which is hosted at paste.osmc.io as we can regularly process the pastes to identify common issues and in turn improve our product.

Doesn’t look like a complete log especially no apt logs in there

You are right there. I only uploaded the log with the errors. I take you would like a full debug log?

Fixed, thanks.

Actually I mixed up to threads, yours is about library updates. But anyway always help to have full logs for context

Here is a debug log
I ran a clean of my video and then music library, then an update of video and music library, then a clean of both.

I don’t remember trying this one myself but it may do the trick…


Thanks but that appears to be related to streaming rather than the actual database containing the music/video library.

Although I think getting rid of old streaming links was the original intent from many years ago, I think if you had looked a bit farther in that thread it shows it has extended well past that. But, after your reply I decided to go ahead and install it on my PC and let it run and take a look at the log of what it found for removal. The list contained both online and local paths for things that were no longer valid links. In the settings I also saw options for manually specifying paths for removal among many other advanced options.

And your database still works? I may give it a try.

I didn’t choose the option to have it actually clean as it also pegged some things I didn’t want removed and I didn’t see the point. I’m using a MySQL db and I didn’t feel like going through the trouble in case something went sideways. A regular Kodi db it can backup as part of the process. I suppose you can evaluate the risk on your own based upon posts in that Kodi thread for it.

Hi, are we talking about these directories?

2021-12-11 11:35:49.249 T:395     ERROR <general>: GetDirectory - Error getting /mnt/helium/audio/DVD Videos/The Complete Truth About De-Evolution (2003) - Devo/VIDEO_TS/

2021-12-11 11:35:49.915 T:395     ERROR <general>: GetDirectory - Error getting /mnt/helium/audio/TV Shows/ Agatha Christie's Poirot (1989)/

2021-12-11 11:35:51.048 T:395     ERROR <general>: GetDirectory - Error getting /mnt/helium/audio/TV Shows/DWTV/

What happens if you manually create these directories, scrape again, remove them and finally process another scraping run?
Just from the semantic it looks like you accidentally created some videos stuff in your mounted audio path in the past?

It could be more helpful to provide a standard log collection:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Here is a copy of the log from the following attempt.

  1. Add DWTV and some contents
  2. Run an update.
  3. Run a clean (See log)
  4. DWTV and contents appears in library - No message in log
  5. Delete DWTV
  6. Run clean (See log)
  7. Message appears in log.

All of my video stuff sits in the audio directory. It was just to make life easier. I seperate them in the sources. ( See Sources)

Tried to reproduce this here by creating a subdirectory, place a movie into it, update the video library, remove the directory and update the lib, again … and cannot provoke the error.

Maybe this entry is different from you setup, in my advancedsettings.xml I use


but this is nothing the most want to use.

I’ve also no idea other than you can purge the video library and re-scrape from scratch, to get a fast solution.