[Solved] Remote stops working after switching TV back on


after some update, don’t remember which month it was, but not more than 2 months ago I started experiencing strange behavior. After I turn on my TV (OSMC is always on on Raspberry Pi 3) I can’t use my remote, but when I restart mediacenter via ssh or run "xmbc-send --action='CECActivateSource'" it works until I turn TV off and on again. “xbmc-send” command doesn’t work always, usually only mediacenter restart helps.

After restart or xmbc-send command it works until I turn TV off and on again. Last year it was happening only after couple of days not using the TV, so it was enough to restart mediacenter once in awhile.

OSMC (latest version with all recent updates) is currently running on Raspberry Pi 3. Connected to TV via HDMI audio-splitter (I have old receiver without HDMI, so I use SPDIF from splitter to get sound on receiver, my TV doesn’t support pass-through from HDMI to SPDIF OUT).

TV: Panasonic TX-P50ST60E
No software updates were done on TV recently.

Logs: https://paste.osmc.tv/ulonuzanux

Try this -


That didn’t help :frowning:

Maybe other options in config.txt could influence that?

gpu_mem_1024=256 hdmi_ignore_cec_init=1 disable_overscan=1 start_x=1 disable_splash=1 dtoverlay=lirc-rpi gpu_mem_256=111 sdtv_aspect=1 dtparam=gpio_in_pin=17 gpu_mem_512=144 dtparam=gpio_out_pin=17 decode_MPG2=0xffffffff decode_WVC1=0xffffffff hdmi_edid_file=1 hdmi_force_hotplug=1

Did you reboot the pi after these changes? It’s required.

Have you unplugged the TV from the wall for a few minutes to allow it a reset?

If none of this helps, you may simply be the victim of poor implementation/standardization of CEC accross brands or a shortcoming of GitHub - Pulse-Eight/platform: Platform support library used by libCEC and binary add-ons for Kodi, the method by which CEC is implemented in Kodi.

Yep, I did reboot the Pi. Let me try again with unplugging TV and rebooting Pi once more.
Just tried, but that didn’t help. The thing is - it was working fine before, what could have change in last couple of months that could bring this issue? libcec update? OSMC update?

Quite possibly.

Found newer libcec version, not yet in repo, let’s try it out.

Good luck. You are on your own from here.

rbp2-libcec-osmc_4.0.2-5 didn’t solve the issue. I guess 4.0.2-1 was the last one working fine, but I can’t find it anywhere on internet. Any idea who could share it?

After last update (Kodi (17.3)) last week the issue has gone.