[Solved] SD mounting issue

I have a Raspberry Pi 2 and I’m a happy Osmc user!
I used to have 2 “big” microSD cards, both with Osmc installed but with different contents and switching when I needed. I was happy with this solution, but finally one got broken.
I decided to change approach: one small, cheaper SD card with Osmc and the two Sd cards with contents plugged into two USB ports through adapters.
I managed to access the content of the new SD (I suppose plain FAT32) in which I’ve poured the backup of the contents of the broken one
I can’t access the content of the old healthy Sd (Partitioned from the Osmc System installation).
Is it possible that Osmc is not able to access a partitioned SD with another Osmc installed? (So I should reformat the Sd to use it as storage)
Or should I think that the Sd (or the adapter) is damaged?
Or is there a special way to mount the Ext3 partition of the Sd on Osmc in order to access the content?

Thank you for any help

It will be automounted under /media if it’s readable.
Logs might show read errors or corruption.

Ok, so I can exclude the SD file system and partitioning…

Now, having plugged both SDs at boot, none has been detected!

Maybe the problem was power delivery, the under-voltage warning blinked:
I use a 2A Asus mobile battery charger (which is the recommended rating as 2A in the limit of the power inlet)
In the Rpi forum I found that 800mA are saved for the board leaving 1.2 A for the USB ports.
I found out that microSD can draw over 100mA and the consumption has grown with storage capacity. The consumption can take place even after writing because of wear leveling operations.
Probably the cheap Usb adapters I used increase noticeably that value.
I couldn’t find the power specs of the logitech universal receiver that is plugged in.

Finally I realized that a voltage drop in the usb cable could be an issue too…

Even though looking at numbers the power should be sufficient, I’ve ordered a 3A power supply, we’ll see!

But mobile chargers are not recommended as they don’t have a stable 5V.


but it says 5V 2.0A…
not more or less 5V at about 2A, if you’re lucky!!!

Somewhat disappointed!

Thank you Sam and fzinken!

It likely does provide 5v, and two amps, just not at the same time. Mobile devices normally don’t need the full 5v to charge so companies are not often keen to spend extra money making charges that can provide stable voltage at full output, or sometimes even at half output. What’s worse is switching power supplies tend to degrade over time so even PSU’s that were once working fine can start having issues under load after they have gotten a bit of age on them.

News: my new 3.0A PSU has just arrived, no voltage warning now.
Still I have mounting problems:
the “big” OSMC SD seems fine as it is able to boot the RasPi and to access its own contents as usual.
When I boot the RasPi from the other “small” OSMC-SD, the “big” OSMC-SD plugged in the USB port with an adapter but it is strangely auto-mounted.
By strangely I mean that the system shows two partitions with fantastic capacities, both over the total capacity of the entire SD, and both showing system folders (media mnt…) while I don’t find the contents in the media folder.
Any Idea?

Logs might provide an insight.

Finally the problem turned out to be the cheap microSD-USB adapter. I figured that out because from a Linux PC I was able to read the microSD through a microSD-SD adapter and not through the microSD-USB adapter.
I bought a branded adapter that worked as expected.

1 Like