(Solved-SDCard corrupt) Upgrade error package 'libgnutls-openssl27:armhf' is missing final newline

#1

Hi
tried to upgrade but having tthe error:package ‘libgnutls-openssl27:armhf’ is missing final newline

Calculating upgrade... Done

The following packages will be upgraded:
base-files bind9-host ghostscript libaudiofile1 libbind9-140 libcupsfilters1 libdns162 libgs9 libgs9-common libisc160
libisccc140 libisccfg140 liblwres141 libmariadbclient18 libpng16-16 libsmbclient libwbclient0 libzzip-0-13
linux-libc-dev python-pip python-pip-whl python-samba rbp2-mediacenter-osmc rsync samba samba-common samba-common-bin
samba-dsdb-modules samba-libs smbclient unzip
31 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 88,9 MB/112 MB of archives.
After this operation, 852 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.fau.de/osmc/osmc/download/dev/gmc-19/public gmc-19/main armhf rbp2-mediacenter-osmc armhf 18.8-40 [88,9 MB]
Fetched 88,9 MB in 1min 42s (865 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages …
dpkg: unrecoverable fatal error, aborting:
files list file for package ‘libgnutls-openssl27:armhf’ is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)

Thanks for looking into it.

T

#2

Your SD card is corrupted

#3

ok thanks will check

#4

top,
sudo touch /forcefsck

solved it at the moment
will buy a new SD Card

#5

Take a backup.

1 Like