Solved: WARNING! Raspberry Pi 1 disk image's checksums are all wrong!

I was about to give this a try, but have not been able to as I have discovered a problem.

All the Raspberry Pi 1 disk image’s checksums are all wrong. This seems very weird to me, as I know what can cause checksums to be different.

Care to give your impressions of this?

It means the file was modified as you downloaded it, or the download was incomplete or corrupted.

I just checked the Pi 1 RC3 image by downloading it and running md5sum on the image and it matched just fine:

osmc@rpi2:~$ ls -al OSMC_TGT_rbp1_20150519.img.gz
-rw-r--r-- 1 osmc osmc 160770320 May 19 22:08 OSMC_TGT_rbp1_20150519.img.gz
osmc@rpi2:~$ md5sum OSMC_TGT_rbp1_20150519.img.gz
71319d4b07066c0da72b02d94bc8b3a2  OSMC_TGT_rbp1_20150519.img.gz

Does your file size match ? How are you downloading it ? Via a proxy or direct ? What AV software is running on your PC ?

$ ls -la OSMC_TGT_rbp1_20150519.img; md5sum OSMC_TGT_rbp1_20150519.img
-rw-r–r-- 1 pi pi 268435456 Jun 17 07:48 OSMC_TGT_rbp1_20150519.img
26180d09c6dcfc54901291fcdcea6b96 OSMC_TGT_rbp1_20150519.img

This was downloaded directly from the following link:

Here are the other 2 images:

ls -la OSMC_TGT_rbp1_20150412.img ; md5sum OSMC_TGT_rbp1_20150412.img
-rw-r–r-- 1 pi pi 268435456 Jun 17 07:59 OSMC_TGT_rbp1_20150412.img
a6f724390a768b5e449943e82583f70b OSMC_TGT_rbp1_20150412.img

ls -la OSMC_TGT_rbp1_20150331.img ; md5sum OSMC_TGT_rbp1_20150331.img
-rw-r–r-- 1 pi pi 268435456 Jun 17 08:00 OSMC_TGT_rbp1_20150331.img
cb238de11c1b21ff7134c79110ac6034 OSMC_TGT_rbp1_20150331.img

Didn’t realize all the file sizes were the same size. Yet, they aren’t the same image. Very interesting. Something screwy is going on. I’m running Arch and using seamonkey to download.

It’s most certainly an issue local to you as, dbmandrake and myself have confirmed md5’s after download to the UK and US from the only mirror that is currently in use.

All mirrors are reporting the correct MD5. The issue is definitely at your end.

Try wget the file or download it without a browser


They’re not the same size. Your downloads are incorrect. Notice that your download size is approximately 256MB while the actual files are around 150MB, (see my ls -al) and all are slightly different file sizes.

I have no idea what you’ve downloaded but they are not the correct images. I would not install them.

I’ve just realised what the issue is - notice your file exentension is .img not .img.gz - your browser is extracting the gz archive automatically when downloading. The extracted size of the images is the same because of the way we generate them. (Compressed sizes differ though)

Change the preferences in your browser not to automatically extract archives on download. (Safari does a similar thing)

You’re right, ty for setting me straight. I did gunzip them before running md5sum. I didn’t realize the md5sum displayed on this website was for the compressed file instead of the actual image that is used.

Advertised md5sum will ALWAYS be for the downloaded file because more often than not, an archive would contain MANY files. This would be in all instances, not just relating to OSMC.

Can you please edit your post or mark it as solved so as not to cause alarm to other users?