[SOLVED] Wifi disconnections even after RC2 update

Hi guys,
I’m having a lot of wifi dropouts with TP-LINK WN725N v2 (Chipset is Realtek 8188eu, id 0bda:8179) on Raspberry Pi 2 & OSMC.

Here is my log file: http://paste.osmc.io/gubuxipiza

I had this problem with RC also. The wifi dongle works fine under rasbmc and Raspberry pi mod. B but seems a bit problematic with OSMC RC and RC2.

If there’s something I can do to help the devs to track down this wifi dropouts let me know :smile:


Do you have more than one AP in your house broadcasting the same SSID ? Such as a second AP or a range extender ? What signal strength are you seeing ?

The log file is full of roaming messages - this usually means the signal is too weak and it is searching for another AP (on another channel) which is broadcasting the same SSID. If the signal is weak enough this triggers a “fast scan” which will cause disruption to the network connection while it scans all the other channels for another AP to roam to.

I don’t have any other AP or range extender.
The signal strength I can see in OSMC (in Network->Wireless) is low, only one dot but iwconfig wlan0 tells me the signal strength is about 70%.

My USB dongle is attached directly on one of the four Raspberry 2 USB port. In another USB port I’ve connected my external 2.5"USB hard disk drive.
I don’t think it’s a power supply issue because my psu is a 5V 3A and the microusb cord is short (50 cm).

At this point I suspect may be a RF interference problem between wifi dongle radio waves and the Rpi itself, so I’ll try the following steps:

  1. connect the USB dongle to the Raspberry pi 2 using a male-female USB cable 1 m long;
  2. connect the USB dongle via a powered USB hub.

I will report the results.

For now, many thanks for the help :smile:

Have you enabled the USB_max_current flag in the pi config section?

Yes, because my HDD won’t start without USB_max_current flag enabled.

You have a spinning drive AND wifi adaptor both powering off the USB ports directly ?

Even with usb_max_current this may not work reliably, as some wireless adaptors use quite a bit of power.

Do you still get problems with the wifi connection with the HDD unplugged or powered from somewhere else ?

If I’ve not misunderstood the meaning of the “usb_max_current” parameter, it permits 1.2 A max shared over the 4 USB ports. In the worst case my USB hdd will take 0.5 A (standard max USB current) and my USB wifi dongle 0.5 A (but it is a little overrated current, I think), so in theory there are 0.2 A left shared between the other two (unpopulated) USB ports.

In any case, I’ll try to connect my HDD (or the wifi dongle or both) via external powered USB hub and will check if it helps.

Many external 2.5" self powered hard drives use more than the standard maximum USB current of 0.5 amps - that’s why you often see cables with two USB plugs at the computer end to plug into two USB ports - to try to skirt around the 0.5 amp limit.

In fact many USB devices widely flaunt the maximum allowed USB power limits, so much so that most USB ports these days can supply considerably more than the standard, to maintain compatibility with these devices that break the rules.

I would certainly try to rule this out because on a less than ideal power supply I often see the low power warning coloured square flashing up in the top right corner on my Pi 2 simply from plugging in a wifi adaptor with nothing else…(it’s ok with another power adaptor however)

Hi, for testing purpose I’m now using a powered 7 port USB hub with my wifi dongle.
The hub is powered with its 5 V 2.8 A psu; on this hub is attacched only the wifi dongle.
The 2.5" USB hdd is still connected via Rpi 2 USB port.
I’m having exacly the same dropouts. Log file is here: http://paste.osmc.io/yuqohuwazi

I think is definitively a driver problem with the new OSMC kernel…


I did a router/AP (TP-Link ) factory reset, then a reconfiguration and my wifi dongle works as expected with OSMC RC2. Strangely enough, with my other wifi devices the previous configuration worked fine except with the TP-LINK rtl8188 wifi dongle on Raspberry pi 2 & OSMC RC2.

Now I can confirm that the TP-LINK WN725N v2 (Chipset Realtek 8188eu, id 0bda:8179) works out of the box without any kind of problem: no more disconnections, fast file transfer etc.

I can confirm that Rpi 2 is capable to feed directly this Wifi dongle and a 2.5" USB hard disk (WD Elements 2 TB) drive at the same time!

Thank you to all the people who made OSMC a great piece of software :smile: