[SOLVED] Wifi passphrase not accepted

Hi has anyone else experienced the issue with trying to connect wifi to router on rp2 running OSMC?
I can only configure my router to security None. If I set anything else that requires a passphrase it won’t connect. Using realtek Rtl8192cu usb wireless adapter with raspberry pi2 osmc and dgnd3700v1 router. Tried keyboard keys and on screen qwerty keyboard. Connection failed. Thanks

Do you have it connected by lan cable as well? If so, try disconnecting first

Hi, no ethernet cable connected and wired is disabled in the settings.

Does the passphrase contain special characters or spaces?

Nope mixture of 12 numbers and letters only

I have read through a lot of searches and attempted what ever they tried with no luck. I just don’t know if I did the data log right. Set kodi log and went though the failed setup then saved it to card. Need to see if I can pull it off the card.

Can you

  • Try connect to WiFi
  • When this fails, connect via Ethernet and upload logs?

CC @gezb

Just downloaded the latest update. No more problems. Wireless passphrase accepted. Thanks for fixing this issue. Very happy chappy.

Did you have a space in the network name or passphrase by any chance ?

My current connect does have 2 spaces in the SSID.

That’s probably it then. RC2’s networking settings had problems with passphrases with spaces in them. However there was also another bug that could cause the password authentication to fail due to the wpa agent taking too long to load - this usually only affected the Pi 1 though.

it did fail on another setup I did with no spacers.

I see that another large update came through last night when I did a manual update? I did have issues with setting up Bluetooth hanging after updating version 3 night before last though. I now need to check if Bluetooth was fixed after last nights update.

Im having the same problem with this wifi dongle http://thepihut.com/products/usb-wifi-adapter-for-the-raspberry-pi.

I can’t connect either the osmc installer or manually. I’ve two networks configured in my router. One main for myself and one for guest and I can’t connect to either of them.
The main network has special characters and the guest just having small characters and numbers.

Have been trying on both RC2 and RC3, no luck.

dmesg output can help us identify the chipset in the dongle and whether it’s supported, a full set of logs should let us see any wider issues.

Sam

I’m completely stuck with this.
The old version of OSMC was working well. Tonight i installed the latest version (new install) and can’t connect to my wifi.

Dongle: r8188eu
Wifi:

  1. hidden, no spaces in SSID, password with special chars → connection failed
  2. shown, no spaces in SSID, password easy (guest network) → connection failed

With connmanctl i could connect, but after reboot still no connection.

I don’t know what to do :frowning:

https://osmc.tv/help/wiki/logs

Same problem here.Simple passphrase of lower case letters.Connection failed.
Does not make sense as its a new install of RC3 which I installed wireless.
Should just work!Two different setups one on RPI other on RPI2 both do same thing.The RPI2 I finnally got going using on screen keyboard took several attemts but all of a sudden it worked.Other no dice.
If it was a wireless install I don’t believe I should have to enter the passphrase in OSMC settings again.Never had to with Raspbmc.

+1 does not help

We need the logs.

Sam

this is my log
http://paste.osmc.io/jepigorepi

i created this in this way:

  • boot without cable.
  • try to connect to wifi from the GUI (connection failed)
  • connect cable
  • upload log

in the log i can’t even see the ssid of my network…