Some Problems, Errors and Questions - Vero 4k+

Hello.

I am a new Member here. And i am a absolute Beginner with Linux etc.

If the Vero is starting i get an error: Failed to start /etc/ rc.local Compatibility

I have set Kodi to use 1080p60 for the GUI, but somtimes Vero and Kodi starts Gui in 720p.

Another question: I have that TV: Panasonic TX-55FZW804
If i play a HDR Movie from my NAS how can i see if the Vero plays the video in correct HDR-Format? With my TV i cant see if the file streaming is in 8-bit or 10-bit. It shows only HDR yes or no.

Here are my log:
http://paste.osmc.tv/ufikigudir

I hope you can help an absolute Beginner. Thank you

Did you try and edit this file to enable 10-bit output?

It can be found from the output of cat /sys/class/amhdmitx/amhdmitx0/config during playback.

For now: make sure you start Vero after your equipment is on; or go to Power -> Exit and Kodi should exit and save the new 1080p resolution. This will be taken care of in the next update.

Sam

thank you for your quick answer.

i tried to do something with rc.local but i cant remember what it was :frowning:
maybe i did some mistakes.

I would recommend reverting any changes you have made to that file.

how can i do that?

You can edit the file with sudo nano and remove any changes you have made to it. See Transferring and editing files - General - OSMC.

thank u i will try.

maybe u can take a look at my logfile? i´ve got some other errors too.

What are the other errors?

If you still have problems: I can prepare a hotfix to restore your rc.local file or you may wish to reinstall OSMC from osmc.tv/download to start fresh.

Sam

how can i prepare a hotfix? sorry for all that dumb questions

the other errors are:
Nov 13 23:08:51 osmc kernel: [amvecm] pq string error !!!

Nov 13 23:08:52 osmc systemd[402]: rc-local.service: Failed at step EXEC spawning /etc/rc.local: Exec format error

Nov 13 23:08:53 osmc connmand[350]: iptables support missing error 2 (No such file or directory)

23:08:54.360 T:4079342160 ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files

23:08:55.414 T:4079342160 ERROR: GetString: error reading /home/osmc/.kodi/userdata/disp_cap

23:05:28.288 T:4080874064 ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files

These messages can be ignored, with the exception of the rc.local message. They are not actually errors

ok thank you. so i wait for the instruction for the hotfix :wink:

Sorry, i have another question :expressionless:

if i play movie with YUF 420 (Mediainfo) the Vero plays in YUF 444. is it ok or normal?

still no answer?

We would need to see a log re. this.

The hotfix code is:

eqobuqoyij

do u mean the debug log from kodi?

A full set of logs via My OSMC

i typed in the code but nothing happend. after restart i got the same rc.local error again

I really need to see a log

1 Like

here is the log: http://paste.osmc.tv/jehixotagi