Sound stopped working

Hi there,

I have been a happy user of osmc for some time, despite the occaisonal SD card corruption :wink:
Anyway, just this week, the sound on my Pi completely stopped working. Am listening to sound via the audio jack linked into my amp. I checked the system settings and everything seemed correct. I was concerned that it was a hardware issue so shutdown, removed the SD card and transferred to a second identical Pi that I have. Unfortunately there was still no sound although everything else works perfectly. I think this rules out hardware issues.

Not sure if this is related to my problem, but at some point just prior to the issue I got a message stating a download or something had failed, I therefore initiated a manual update which ran without any errors.

Anyone got any ideas?

Nope…

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

Sorry ActionA - my bad. Appreciate you pointing me in the right direction!

I enabled debug logging, rebooted and tried playing some music. I also disabled the last addon I installed (youtube) in case that was the problem…

http://paste.osmc.io/ateworaqix

Hope there is something obvious in the logs!

I am guessing that there isn’t anything obvious. Would you recommend a reinstall? If so, then the only thing I really want to retain is which movies / series i have watched. Is this possible to restore from a backup? Sorry if this is asking the obvious…

https://discourse.osmc.tv/search?q=keep%20watched%20status

Sorry but, I myself have not looked at your logs and it appears only 3 have downloaded it. I have no need to download other peoples logs simply so I can read them once and then have to dig around and find the file to delete it from my system. If you want it more widely viewed, please use the method clearly outlined in the link you were provided for submitting a useful help request. It’s quite simple to copy the contents of your log to paste.osmc.io, press the save button, and provide the resulting URL so that others aren’t unnecessarily bothered with your download.

ActionA, I’m not sure I completely follow your last post- I followed the instructions that you sent including putting the logs in paste.osmc.io so not sure what you were expecting from me.

Anyway it seems like I have offended you by my actions - my apologies if I have. In the interest of moving forward I will just try and sort this out myself.

  1. Check (and maybe post) what you have configured as “Audio Output Device”
  2. Check that you not by accident have muted (or low volume) your device.
    Odd muted status in upper right corner after upgrade

Hi fzinken - thanks for your message.

I tried all the different options on the Audio Output Device, but currently have it set to both HDMI and analogue.Volume is also maxed out. I can hear some static / burbles when navigating / playing music. Its not recognisable as anything so could just be static, but that is why I thought it was a hardware fault so swapped out the Pi.

Maybe temporary try to remove your configuration with
mv .kodi .kodi_backup and reboot

If that solves the problem we know better where to look.
Afterwards restore with
mv .kodi_backup .kodi and reboot

OK so the issue does seem to be something to do with a setting in .kodi. The only difference I could see between .kodi and .kodi_backup was the latter had an additional folder called sounds.

I tried selectively bringing back folders to see which one had the issue, but can’t work it out. Unfortunately somehow my ability to connect to the Pi via Kore on my phone seems to have been lost and aside from ssh I can’t contact the Pi. On the plus side I can hear system sounds so think the sound is sorted (no idea how or why though).

In light of this, am thinking a reinstall may be best. All I need to retain is which movies / series are watched. Where is this info stored?

userdata/Database contains libraries so just restore that folder to a fresh install

Thanks Dilligaf.

So I just did a fresh install and put back in the userdata folder. Amazingly this seemed to stop the sound. Anyway after swapping out some folders - can’t remember exactly what I did though, the sound is back and working with all my files. So first issue solved - thanks for all the help!

What is strange though is that I could not connect to the system using either the ‘Kore’ or ‘XBMC Remote Music Pump’ apps on android with either the fresh install or the one with my previous userdata folder . I did see a message stating that the ‘CEC Adaptor’ couldn’t be connected and to check settings. When I disabled this in system settings > Peripherals, I was able to connect with the ‘XBMC Remote Music Pump’ app, but not the ‘Kore’. Is there something I am missing, but this just used to work out the box… Should I start a new thread?

I reset the android apps and can now connect so everything is sorted - thanks for help…