Soundbar problems after December update

sure thing.

Audio config: https://paste.osmc.tv/rimilumixu.xml

New logs with debugging on: paste.osmc.tv/etequsupep

A screenshot would be easier to see visually.

Screenshots: postimg.org/gallery/pc9a53ks

Hi,

Thanks for that.

Can you let us know the make and model of the soundbar so we can check its capabilities? I notice you have DTS HD enabled for example, but not DD. It seems strange that DTS would be supported but not DD.

If you disable passthrough temporarily and reboot, do you get audio? I’m not suggesting this as a long term solution.

Sam

Yeah the make and model is Yamaha YAS107 7.1 Soundbar. Prior to the update it worked fine and I haven’t changed any settings. I am getting some audio, for instance, I hear the theme tune just not the actors speaking. Other audio (like this: https://paste.osmc.tv/iyosoqexop.vhdl) work fine. This audio is also having the same problem too, which used to work fine: https://paste.osmc.tv/inegiduluv.vhdl

Rebooting and disabling passthrough does not make a difference. I still hear everything other than the voices.

Hi,

Sounds possibly related to:

We had some issues before where audio channel mapping was incorrect. This has now been resolved and may explain why you have noticed some issues now.

Your receiver only seems to advertise the following capabilities as supported to OSMC:

====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/96/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz,  bit
Dobly_Digital+, 6 ch, 32/44.1/48 kHz, 16 bit
DTS, 6 ch, 44.1/48 kHz,  bit

My recommendations are:

  • Set channels to 2.0
  • Enable passthrough for Dolby Digital and DTS and Dolby Digital Plus (E-AC3) receiver.

Should I enable AC3 transcoding?

No – it should not be necessary.

The audio now seems to be working, thanks. Will this still use all of the channels or limit it to 2.0?

The soundbar says that it only supports 2 channel LPCM.

If you play a multi-channel track that is not DD, DTS or EAC-3, it will be downmixed to two channels. If you enable AC3 transcoding then you can have it sent as 5.1 channels instead. 5.1 channels via AC3/DTS/DD is the highest configuration that your receiver advertises support for in its EDID.

Sam

so the device will only play a maximum of 5.1? is there a reason that the device isn’t advertising 7.1? is there anywhere you’d suggest me looking in to to resolve this?

I don’t know a lot about the device, but it’s EDID suggest it only accepts 2 channel PCM. So when we try and send 7.1 channels to it, it doesn’t work properly.

With the settings suggested above, it will sound better than it did in the previous months you’ve been using it with your device.

If you have a link to the manual, it might confirm what the bar can and can’t do.

Sam

I believe this is the manual: YAMAHA YAS-107 OWNER'S MANUAL Pdf Download | ManualsLib

From p22, it looks like you should be connecting vero to the soundbar. Then vero can get the correct EDID.

Let us know if that upsets video.

Didn’t realise @liam1213 wasn’t doing this.
For OSMC to properly query those audio capabilities, it should be connected so that:

Vero 4K -> Soundbar -> TV

Sam

I have just set it up like the manual. The video seems to be fine. Shall I post the logs?

Might be useful for confirmation of audio and video capabilities, thanks.

no problem.

Logs: paste.osmc.tv/ekawimegal

OK, now we have:


====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/88.2/96 kHz, 16/20/24 bit
PCM, 6 ch, 32/44.1/48/88.2/96 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz,  bit
DTS, 6 ch, 32/44.1/48 kHz,  bit

which means it’s advertising support for:

  • DTS
  • AC3, (not E-AC3)
  • 5.1 LPCM

I’d set channels to 5.1 + Fixed.
Disable E-AC3 passthrough
Enable AC3 transcoding.

Sam

If I put It to fixed, I can no longer edit the passthrough options, should I put it to best match and disable E-AC3 and enable AC3 or leave it at fixed?