Space error when adding file to my music library -

I’m running OSMC on a Raspberry Pi 3b. I have a 32 GB flash drive attached. Here is the entry in /etc/fstab:

UUID=“9206-E16B” /mnt/medialib vfat defaults,dmask=000,fmask=111 0 3

And from the DF command to show usage:

/dev/sda1 30027760 18256720 11771040 61% /mnt/medialib

I recently tried to add music from John William’s 3 disk set, but got errors for some of the tracks, see attachment. MediaCenterFileTransfer

If I read the DF output correctly that device is only 61% full and thus there should be plenty of room? The example file in the figure is about 12 mb, but I have others which are in the 4-5 mb range.

Obviously there is something about this that I’m not understanding. Can someone enlighten me? Thanks…RDK

Edit: additional info, Medialib is shared to my network using SAMBA and I’m copying the files from a folder on my Win 10 computer to that share

Is the SD formatted in exFAT? I remember having an issue where if a drive attached was exFAT and I was accessing it from Windows 10, then any failed transfer would take up the space it would have. Deleting files over the network also did not recover the file space. Whatever the issue it seemed to only affect exFAT and only when it was interacting with Windows. I think I tried fixing the issue by running drive scans on both Linux and Windows with no success. Reformatting brought back full usage of the space.

OK, I will copy and reformat, What flavor of format do you suggest? It is a 32GB flash stick…RDK

If your planning on only using it connected to your RPi and swapping files via the network then ext4 would probably be a logical choice. If you want to be able to easily read the drive in Windows as well without any special accommodations then I would go with ntfs. Be aware that there will likely be a performance reduction in Linux using ntfs vs ext4.

ok, I’ll give ext4 a shot. Thanks…RDK