Ssh doesn't work after Oct 2020 update

Please help me.

Today I updated osmc to version of Oct 2020.

But then, I cannot connect ssh anymore after it. I checked CLI console mode and sshd service failed.

It says status 255 exception and “Failed to start OpenBSD secure shell server.”

Please help me. I ssso regret to update it…

Please post logs.

What logs should I post?


Just do grab-logs -A

Does Kodi run? Is ssh the only problem?


Mediacenter is fine. Only ssh doesn’t work.
I just removed openssh and then installed it again but it’s still not working.


Assume you installed via command line?
If so where any errors shown?

Actually forget that.
Check your sshd.conf


28 15:38:24 osmc sshd[474]: /etc/ssh/sshd_config line 41: Bad SSH2 mac spec ‘,,,hmac-sha2-512,hmac-sha2-256,,hmac-sha1,hmac-sha1-96,hmac-md5,hmac-md5-96,hmac-ripemd160,’.


I also saw this but what should I do with this? Remove all of them?

E.g. that was removed with version 7.6

But you most likely have to check one by one

You could manually edit the sshd_config file and replace that line with:


That’s what’s in my sshd_config.

I edited same as you but right before, I removed sshd and reinstalled so I have no sshd service.

Instead, I have ssh service which is masked now.

Can you help me plz…

If you removed it and re-installed and it’s still not working, post logs again.

Now there’s no sshd service.

I wanted to install ssh in osmc GUI but it also didn’t work.



sudo apt install openssh-server --reinstall

Sshd service is installed!!
But I guess it doesn’t refer sshd_config.
I changed ssh port but it’s not listening.

Why would you do that? So it ssh now working?

No it’s not even working.

Sshd service is active but cannot connect to this via ssh.

Do I actually need to ask for logs again???

1 Like


I think sshd was started with /usr/bin/sshd before but now it is started with /etc/init.d/ssh

  1. what is the output of sudo systemctl restart ssh
  2. Please share your sshd config paste-log /etc/ssh/sshd_config