SSH Not working via PC

Ok have always been able to talk to my Pi via SSH from my PC until today and not sure how long it’s been broken.

All I get from putty is “Network error: Software caused connection abort”, If I try an app I have in Windows 10 it says “Server HMAC algorithm not found, Press Ctrl+R to reconnect”

I ended up uninstalling by running sudo apt-get purge openssh-server then reinstalling it sudo apt-get install openssh-server along with sudo apt-get install ssh-app-osmc then run update after.

Still didn’t work so tried Termius on my iPad which worked and connected fine.

If found this thread about a May update and then this bit:-

The immediate issue is related to a hardening of SSH in the May update that is causing problems on your system. As a temporary workaround, you should edit file /etc/ssh/sshd_config and comment out the lines:

See this2 for details of accessing the command line without SSH. Alternatively, since you’re using a Pi, you can also shutdown the machine and edit the card on another computer.

Edit: I’ve tested the new sshd_config file and it works fine on my machine. I suspect your link to Debian unstable (“sid”) might have caused unforeseen problems.

Edit 2: Sorry, I forgot to mention which file to edit, :wink: Error now fixed.

Which when I edit out now works on my PC but this says temporary, what’s the permanent fix I don’t want to leave it insecure.

Can you try updating the version of Putty that you are using?


Ok that worked, had to make sure I commented the entries back in and old version didn’t work, new one did.
Simple as that :slight_smile: