Still won't update

For the last few days, I’ve been receiving a message that an update has been downloaded, but I always get a message saying there was an error updating and I should notify Osmc. Osmc is running fine, but I’d like to get the update installed. My logs are at;

Thanks for any help.

Turn on debugging in the Kodi settings and run the update again. Then if it fails, send that log through.

The downloaded update is corrupt:

Log started: 2015-08-12  06:01:36
Preparing to unpack .../rbp2-mediacenter-osmc_15.1.0-0_armhf.deb ...
Unpacking rbp2-mediacenter-osmc (15.1.0-0) over (15.0.0-9) ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive /var/cache/apt/archives/rbp2-mediacenter-osmc_15.1.0-0_armhf.deb (--unpack):
 corrupted filesystem tarfile - corrupted package archive
Errors were encountered while processing:
Log ended: 2015-08-12  06:02:49

Try deleting this file from the cache to see if it will download it again.

Ok, I deleted the file and rebooted. Then I turned on debugging and manually scanned for updates, but the file won’t download now. In the box, it says “Download Started” but even after waiting for hours nothing happens. I pulled the logs as before, but there doesn’t seem to anything in them. Here they are:

The actual url shown in the dialog box looks like it has an extra space added for some reason so it looks like this: gibexutuyu

Neither one seems to have anything in it. Any idea what I should try now?

Looks like you have file system corruption:

[  301.300006] EXT4-fs (mmcblk0p6): error count since last fsck: 1
[  301.300046] EXT4-fs (mmcblk0p6): initial error at time 1437657572: __ext4_read_dirblock:884: inode 267746
[  301.300080] EXT4-fs (mmcblk0p6): last error at time 1437657572: __ext4_read_dirblock:884: inode 267746

You need to run fsck on the filesystems. Unfortunately in the current release that isn’t easy. In previous version you could hold down shift at the start of boot but this no longer works in the current version.

Your best bet would be to mount the SD card in another linux system so you can run fsck from there.

Thank you for your help. Unfortunately, I don’t have another linux box so I’ll have to try to find or build one. Can this be done via ssh? BTW, the splash screen that comes up when the Pi boots says to hold shift key down for recovery; is that not available or is it something different than fsck?

Thanks again.

Not when the file system is mounted read write, and you can’t remount the file system read only when the system is running.

From your log file it looks like you use a Noobs install - what other operating systems do you have installed ? If you have Raspbian installed you could run fsck on the OSMC partitions from there.

Unfortunately, I can’t get into the recovery console and the only thing I had installed was osmc. I tried to use virtualbox with Ubuntu 15.04 to try and run fsck, but it wouldn’t run through the reader I had the micro sd in.

For now, I’ve just disabled looking for updates and am just using it as it is.

I’ll keep trying though. Thanks for all of your help.

Unfortunately the recovery console was broken by the move to a 4.1 kernel in the July update - sometimes it still works if you press shift at exactly the right moment as the OSMC splash appears, but it no longer works when you hold down shift from power on, due to some change in the way the kernel initialises the keyboard on boot so it can be very difficult or impossible to get into depending on your keyboard.

Rather annoying as I spent some time originally creating the recovery console only to see it neutered by a kernel update, but we couldn’t really hold back a kernel update for that one feature so reluctantly accepted that it would be broken for the moment with the hope of fixing it again in the near future.

Finding the change in the kernel that has caused it could be extremely difficult and time consuming though and unfortunately low on our priority list… unless there are some kernel guru’s in the audience that want to chip in and take a crack at it ? :wink:

Well, I’ve finally had a chance to look at the SD card in a Linux environment and this is what I got when I ran an fdisk command and an fsck command.

fdisk command;
Disk /dev/sde: 7.4 GiB, 7948206080 bytes, 15523840 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00066265

Device Boot Start End Sectors Size Id Type
/dev/sde1 8192 1675781 1667590 814.3M e W95 FAT16 (LBA)
/dev/sde2 1679360 15458303 13778944 6.6G 85 Linux extended
/dev/sde3 15458304 15523839 65536 32M 83 Linux
/dev/sde5 1687552 1851391 163840 80M c W95 FAT32 (LBA)
/dev/sde6 1859584 15458303 13598720 6.5G 83 Linux

fsck command:
root@debian:~# fsck -fv /dev/sde2
fsck from util-linux 2.25.2
e2fsck 1.42.12 (29-Aug-2014)
fsck.ext2: Attempt to read block from filesystem resulted in short read while trying to open /dev/sde2 Could this be a zero-length partition?

Two things I find interesting is that this is an 8gig card, but it’s showing over 13gig in size and the zero length partition message on sde2.

Any ideas? Thanks again.

sde2 is shown as an extended partition - which I take to mean a pseudo-partition which can contain several real partitions. I don’t remember seeing one of these before, as I only have had windows style extended partitions.

You could only expect to run fsck, meaningfully, on sde1, sde3, sde5, sde6

Ok, thanks. I did run fsck on those partitions and any problems were “fixed”. Unfortunately, when I tried to run updates through osmc, it still never got past “Starting Download”. I guess I’ll just have to reformat the card, download Noobs again, and see about getting my mpeg license re-installed. Thanks again.


If you’re having that much difficulty keep in mind that there is probably a hardware issue underlying the problems you’re seeing - file system corruption won’t happen for no reason and could be the early signs of a failing SD card or power adaptor for example.

I hope it was just me not being familiar enough with the Raspberry Pi 2 and the correct way to shut it down. I must have unplugged the power once too many times…

Just wanted to thank you all again. I’ve formatted the card and re-installed osmc; the system updated as it’s supposed to and I’m running the latest version. At least I now know much more about working on Linux systems then I did before. :smile: