Stop start of transmission on boot

Hi, I have installed tranmission-daemon on OSMC system in Raspberry Pi 2.

It start when I boot the system (power off or restart) and I need that It don´t start because I have to start with my script that mount a external NAS as respositories of transmission.

I tried with:

  • “sudo update-rc.d -f transmission-daemon remove”
  • removing the transmission-daemon from /etc/init.d

/etc/rc.local only have “exit 0”

Some ideas about how can stop the start of transmission-daemon on boot?

Thanks

sudo systemctl disable transmission.service

The commands you’re trying to use are legacy sys v init commands - OSMC uses systemd init.

Also, you can enable/disable services installed from the App Store in the services section of My OSMC.

Thanks for your answer but it don´t work in my system.

I reboot the system and transmission start in the boot.

I installed transmission-daemon using apt-get and OSMC app store don´t consider transmissión installed.

Thanks

It’s possible that the standard version of transmission doesn’t use a systemd service. Try using the App Store version instead.

ok, I will try.

Thanks