Struggling with TV shows

Afternoon all.

Just received a vero today and trying to set up some simple stuff.

I have 2 issues that I’m sure are simple to solve

  1. In osmc there is no TV shows section on the left - i can see it in customise main menu though
  2. When I change to Estury - I see a tv show but when I set the source folder it doesn’t populate the tv show section.

pointed to my NAS : multimedia>Series>TVshows

Does anyone have any ideas please :slight_smile:


How are you setting the source? When adding library location via the GUI, you must select a TV show scraper.

1 Like

Thanks yes,

I’ve tried the two scrapers that are preloaded in.

In the meantime I’ve set a custom action to access them just as “files” not pretty but at least I can see them.


TV Shows will appear once you have a library and have scraped some TV Shows. Then you won’t need to rely on the files option.

1 Like

If you follow the official Kodi wiki and it doesn’t work maybe just try reinstalling osmc and see if it works then.

1 Like

Thanks I have plenty in my TV folder on my Nas, but not being found in osmc.


Done this, how would I reinstall on a Vero please, I’ve never used one until today, used to using fire products.


Thats why I embedded a hyperlink

1 Like

Sorry my bad, should read properly.

Thanks again.

Upload some (debug enabled) logs (via MyOSMC) that could tell why the scrapping is failing

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


I have done a fresh install this morning and still not working.

Here is the log of me adding a TV show folder and scanning for TV show content.



Guess you would have to clean up your folder naming, check

There are also renaming and media management tools that allow you to do that automatically

1 Like

Thanks will give that a go tonight with a single folder to check it works

Thanks again a


This cured it a couple.of folders threw out the whole scrape.

Got my evening sorted now to rename and organise everything.

Thanks for your help