Stuck in a sad face loop

So I went to Music > Artists > Selected my artist > CRASH. Sad face. Oh dear.

So I waited for Kodi to reload.

Black screen. Sad face.
Black screen. Sad face.
Black screen. Sad face.

Oh dear.

I guess there’s some issue with accessing the MySQL Server, but should this issue be handled better?

After restarting the MySQL server I tried again and had the same sad face crash after a lot of waiting for the albums by artist to load. There was nothing in the kodi.log this time though and Kodi re-started fine.

So I tried again, and this time the albums by artist list loaded fine. This seems like a buggy area; I seem to remember Kodi crashing when loading this list before. Perhaps it’s too resource intensive for the Pi (2)?

I backed out of the album list and got the sad face crash again :frowning:

Turning on debug doesn’t seem to show anything:

After that last line of attempting to load a screen of albums it just crashed again.

grab-logs -A please.

I think it’s the Eminence 2 skin. When I switched to Confluence everything seems to work, and quicker.

That skin is a bit of a pain to install, the developer points to Github for script.extendedinfo, script.skinshortcuts and - assuming the Jarvis branches but some of those won’t install because of missing deps.

I’ll just stick with Confluence until Krypton is out and try the new default skin and hopefully Eminence will be stable then.

But yeah if this ever happens OSMC enters a crash/reboot loop

11:42:30 1265715.750000 T:1956672432 ERROR: SQL: [MyMusic56] Undefined MySQL error: Code (23)
Query: SELECT idVersion FROM version

Spoke too soon. Still getting a sad face crash when navigating around in to albums etc. It seems pretty random.

Here’s the full logs you wanted:

Your kodi logs do not show any crash while debug logging was enabled.

Indeed, but I can assure you after the last line was written to both new and old logs OSMC crashed with the sad face.

Then it won’t be simple to debug. You can start by renaming ~/.kodi and then rebooting. If (most likely, when) it then boots, add back your settings and configurations piecemeal until you begin to see the crashes return. You’ll then have a general idea what setting/config/addon or whatever is causing it.

If you truly suspect it’s some issue with MySQL connection, you may want to sort that, or ask Kodi why such a problem is not handled more gracefully.

Run mysqlchk and try recreating the database


mysqlcheck came back OK on all tables on both databases, with the default options.

I’ll try the other suggestions later.


I renamed the .kodi directory and started fresh and everything was fine until I installed the Eminence 2 (Jarvis) skin. Strange though, because I uninstalled it and the plugins it installed when I was testing before and it still crashed.

So I guess the skin or the plugins it enables are to blame.

An idea for grab-logs (if it doesn’t already) is to be able to specify an alternative .kodi directory (I was going to compare the logs).


use paste-log for that

Cool, how does it work?

osmc@osmc:~$ paste-log --help curl: Can't open '--help'! curl: try 'curl --help' or 'curl --manual' for more information curl: Can't open '--help'! curl: try 'curl --help' or 'curl --manual' for more information Unable to upload log. Please check your internet connection.

paste-log <file name>

I’m not sure how that would provide the same output as grab-logs but from a .kodi or .kodi.old directory? Could you explain?

paste-log ~/.kodi.old/tmp/kodi.log

It won’t provide the same compilation of logs of that’s what you are asking.

Well it would not be the same as grab-logs -A as grab-logs -A would also upload files from outside of the kodi directory.
But you could use it to upload .kodi.old/temp/kodi.log which would be the kodi log of your backup.

I thought it would be useful for grabbing the other logs to see which addons were installed/enabled as we already established the kodi log doesn’t contain anything useful to debug it.

It’s sorted now anyway, thanks for your help!