Stuttering (some) videos, from NAS and even USB

Hi everyone,

I have a RPi 3 plugged into my TV through HDMI, OSMC installed and a NAS with my media files.
This is my first installation.

When i play some video files i get stutters every about 2-3 minutes : the sound is ok but the image slows down and then accelerates ! It depends which file i play.

I tried OMX, MMAL, from the NAS, from a USB key… I don’t know what to do ! Of course the file plays well on my computer with VLC player.

My logs

Do you need media info of this file (and maybe of a file which plays well…) ?

Thanks a lot !!

Best too if you can provide media info & a clip of the video with the stutter. Also, if you can keep it at 200-300MB that would be swell :smile:

Your log shows that you’re running a kernel that doesn’t seem to have come from OSMC.

Nov 03 18:16:42 OSMC_Orey kernel: Linux version 4.14.83v7-aufs (max@lynx) (gcc version 8.2.0 (Buildroot 2018.08-gbbba56f1-dirty)) #1 SMP Wed Nov 28 22:52:43 CET 2018

Could you explain what it is, and why you think it’s not the cause of your problem?

1 Like

I try to give you soon a short clip of the video, need to cut it :blush:
Here the media info

Complete name : Game of Thrones - S06E09 - Battle of the Bastards [VOSTFR].SDTV.avi
Format : AVI
Format/Info : Audio Video Interleave
File size : 540 MiB
Duration : 56 min 48 s
Overall bit rate : 1 330 kb/s

ID : 0
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings, BVOP : 2
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Muxing mode : Packed bitstream
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 56 min 48 s
Bit rate : 1 189 kb/s
Width : 720 pixels
Height : 404 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.164
Stream size : 483 MiB (89%)
Writing library : XviD 64

ID : 1
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 3
Codec ID : 55
Codec ID/Hint : MP3
Duration : 56 min 47 s
Source duration : 56 min 47 s
Bit rate mode : Constant
Bit rate : 128 kb/s
Channel(s) : 2 channels
Sampling rate : 48.0 kHz
Compression mode : Lossy
Stream size : 52.0 MiB (10%)
Alignment : Split accross interleaves
Interleave, duration : 24 ms (0.60 video frame)

I really don’t know, i installed OSMC through Berryboot.

OSMC image available on this page

I’m a newbie :confused:

Well that would explain it. Try to reinstall from the Official OSMC download page

Berryboot is not supported.
It changes kernel and firmware so we cannot offer any support.

Use NOOBS if you need multiple OS support.

Hi dillthedog,

OSMC re-installed, using NOOBS.

Same issue… My new logs :

Thank you again :slight_smile:

I suspect your encode is bad. Have you tried other files or is the problem only with the GoT files?

Hi bmillham,

I’m playing other files right now (The Walkind Dead, some movies…), so far so good !
The problem seems to only happen with some GoT files (some in SD quality, none in 720p quality).

i’ll keep testing tomorrow with other files…
Thanks !!

If you could get a sample of one of the problem files (1 minute or so) that could help find out the problem.

Here the file Dropbox - File Deleted - Simplify your life

Same issue with it…

The file plays fine on my Pi3B+ with Leia v18 if and only if I deactivate OMX and MMAL hw acceleration support at settings -> player -> video. I think this is a typical sign that something is wrong with the coding.

Thank you JimKnopf, it works !!!
I thought it was necessary to activate at least one hw acceleration :thinking: