Subtitles display format tagging - possible to disable?

I have som mp4 files that comes with internal subs. However, when I play the file and enable English subs (volume is low not to wake the kids) the format tags are displayed. So every line of the subtitles look like this:

[font color="#ffffff"]This is the subtitle text[/font]

Anyway to hide the tags and only display the subtitle?


I never had or heard of your issue before but it try this:

Download mkvtoolnix ( it’s free)

Drag and drop your mp4 file into it
Select the subtitle string
Chose the right language in the subtitle settings menu
Create a mkv
Play the newly created mkv file with the same content as your mp4 on your vero and see if the issue is fixed

Ps: Is the font color tag still displayed on screen if you try to play the problematic file on pc using vlc, mpc-Hc or similar?

Might be a bug with the subs themselves. Do you have a link?

It’s a timed text (3GPP) subtitle implicit the mp4 file. If I rip the sub with mp4boxgui to a .srt it displays everything correctly.

VLC has the same issue and reports it as:

Stream 2

  • Codec: tx3g
  • Type: Subtitle

If VLC is also affected it’s probably not a Kodi issue