Subtitles rendering across multiple frames

I have been unable to figure out what is causing this but the picture slideshow tearing mentioned by @koichirose sounds related.

Does anybody else have this issue?
A friend of mine noticed screen tearing on movies, too and now I can’t unsee it.
Since nobody else seems to be talking about it, maybe it’s settings related? Or a reinstall would fix things?

Has anyone checked whether this is a general v19 issue or OSMC-specific?

I can’t comment on whether it’s a general v19 issue, but just want to confirm I have experienced exactly the same issue as others in this thread on my 4K+. Only started on v19, but I see it consistently across a range of different codecs and subtitles.

i don’t think the issue is necessarily introduced by v19 but by the new kernel.

I think @tanio99 reported some improvements in a new kernel we are working on ( > 4.9.113); but this is some way off general release.

1 Like

Any news about this? Can we help figure this out?

We will move to a new kernel in the near future. This already solves subtitle issues with some films.

I’m having this issue as well. I’m new to OSMC. Got my Vera 4K+ a few months ago and I noticed this out of the box. My Vera replaced a HTPC with madVR which does a great job rendering subtitles which probably made this that much more noticeable to me.

We have a new kernel but it’s still in testing and come after Debian Bullseye. From our internal testing, this has solved a number of issues.

I’ve sent you a PM to a USB/SD version of OSMC with this kernel in case you’d like to try it.



1 Like

Is it the kernel that was just released a few days ago or something else?

No – this is something else.

I’m experiencing this issue as well. A new subtitle line will render partially on one frame and finish on another creating a choppy experience.

I’ve only noticed this on anime, which I mostly have encoded to HEVC for Vero4k. Other media will sometimes have subtitles but I haven’t noticed this issue. This could be because I don’t pay attention to them before I turn off subtitles for English audio media or this issue only occurs on certain formats and encoding configurations (HEVC, 10Bit depth, etc.)

As others have said, I only noticed this after updating to Kodi 19. If necessary I can attempt to troubleshoot with debug logs and more evidence. However, I see @sam_nazarko suggested a new kernel may fix some issues, possibly this one. If this could be shared with me as well I can report any changes.


@glc650 if you have the image of OSMC with the new kernel, could you share it? Haven’t heard from Sam yet, and this issue is driving me bonkers.


Any news about this?
Thank you!

You can get the new kernel via the Bullseye testing thread.

Bullseye doesn’t fix the issue, unfortunately.


I’ve noticed that as well.

Just want to say I upgraded to v19 recently and experience the exact same thing.
It’s frustrating but I guess able to live with.
If ever there will be a fix would be great though :slight_smile:

This issue is on my todo list. And as long as @Chillbo keeps nagging me it isn’t forgotten :grinning: