System stuck while exporting library

Hello to all.

As I purchased a larger hard disk for my (single bay) NAS I’m trying to move all of my library to it. The library was previously on an external USB drive connected to the NAS so, due to the path change, if I just copy the files over to the NAS I will lose all the resume points and view information.

I’m then following this procedure but get stuck in the export phase as after some folders are correctly exported the interface freezes and the process stops, though the RPi remains alive (to the point that I can ssh and sudo reboot it to have the system back at work again).
When I say that the interface freezes I mean that the Pi remains somewhat unresponsive after phase 6 of step 1 has started. What I see on the NAS is that in the folders up to the one currently listed in the popup window indicating the process advance, all the files and folders are created (actors jpegs, nfo file etc.), while from that folder on, the content is still the same as before (avi/mkv file, subtitle if any). Pressing the “OK” button (I’m using CEC) to Cancel the operation leads to no effect even though, as I mentioned above, under the hood the Pi is definitely alive and accessible.

I decided to leave it on overnight and have a look if something changed this morning; I couldn’t access the TV as I was already out when I remembered (cough!) and remotely accessed the NAS only to find out that nothing cnahged from yesterday evening.

As I already tried two times to do it, both with the same problem, is there anything I can check to see where the system gets stuck?

No one has a hint?

I noticed that I can recover the system without rebooting (though still needing ssh) by stopping and starting xbmc (mediacenter)