Terminal Mode on Raspberry PI2

I an a newbie, anyway, I downloaded the OSMC image for the R-PI2 from the website, installed it, and everything is working fine, I’m playing 1080p videos from my home server without any problems and after a few adjustments the picture quality is quite good. The issue I’m having is that I cannot get subtitles to play. I saw where I needed to install - sudo apt-get install libass5 in the terminal mode in order to rectify a subtitle issue. However, I cannot seem to enter the terminal mode. When I exit OSMC and hit escape I get a prompt for a username and a password. I never entered a username and a password, so I tried OSMC as suggested in the doc’s, but I go right back into OSMC screen. How can I get into the terminal mode to make the sudo change. Thanks

This library is already included since RC.

The issue I’m having is that I cannot get into the terminal mode to install the library.

Are you on RC?

Yes, I am using OpenELEC-RPi2.arm-5.0.7. I must admit I feel like an idiot asking this question. Thank you for your patience.

OpenELEC is not OSMC. Use the OpenELEC forum

Oops, I meant OSMC_TGT_rbp2_20150315. I tried OpenELEC, but I thought OSMC was a little better. I assure you I am using OSMC, sorry for the error.

https://osmc.tv/help/wiki/console

To install the library that you don’t need to install because it’s already installed you mean ? :wink:

My issue is as follows, when I do the following per the instructions:
-Navigate to the power icon in Kodi
-Select Exit/Quit
-Wait for the OSMC splash screen to appear
-Press ESC on your keyboard
-Login to your device using osmc for the username and password

I go right back into the Kodi main screen. What do I need to do to stay in the terminal screen?

So you are logging in successfully with osmc and osmc for username and password ?

Are you sure you’re pressing the escape key and not switching consoles with ALT-Fx ?

As soon as you log in Kodi will not be relaunched until a few seconds after you log out.

Well, I booted R-PI2 this morning and now everything is working fine. I thought I saw that some updates were installed, but wasn’t sure. Thanks for your support and patience. I will now donate some $$$ to show my appreciation…