[TESTING] 4K HDR playback with banding & flickering fixes

14

So this should be right.

Why do one have to wait up to 1 minute until the effect becomes visible?

Yeah that should be fine. Currently it’s a workaround, a timer that sets the round1 attribute which gets rid of the banding. The real fix won’t have that delay.

1 Like

Hi Sam, any ETA for pushing avg Joe’s fix ? I have my box sitting around for almost a month now i guess waiting for some not DIY workaround when you get back from long days at work. No disrespect, but my time is short home so i only need to play my files not to push some command lines especially if i have some company… Meanwhile, i don’t play 4K hdr movies on it.

Personnal note: HDR issue got discovered “many months later” only because “hdr rips” weren’t that spread before and i personnaly learned about V4K only in december when looking at a different solution than my old PC and Kodi Xbox One for playing them…
What would be interesting is to see if people with different oled brands (like sony, philips or panasonic) are getting the same issue but hard to tell if many are same situation as me (not having time for forums, command lines etc…), so not reporting or bothering for the few owners who got a V4K.

Anyway, thanks for supporting your product, i chose yours after long days of debating against NV Shield TV so i hope for the best.

Hi! Some users have issues with projectors so it’s not exclusive lg oleds I believe. Also, not the solution you want perhaps but running this build and adding one line to rc.local will get you flicker free banding free hdr stuff at any hz, without any fiddling while playing. The only downside is it can take up to one minute before the banding dissapears.

Hopefully we’ll have a better solution soon :slight_smile:

You can update for now and it should work reasonably well. No command line intervention is needed

Sam

It should be fixed properly now.
I’ll also fix banding on the Kodi menus shortly as that has been brought to my attention.

Awaiting feedback from @Martorias @mule @chamelious et al.

Thanks for the testing and feedback.

No update available for me.

Are you updating via the staging repository?
This hasn’t been pushed as a general update just yet.

Just got the new update and can confirm: Banding is now fixed!
@Sam: Great Work!

1 Like

No, if someone posts a link to how, i’m happy to try

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Did some testing today … works like a charm :+1:

I already told Sam but it works fine for me as well

How long before the general update OTA for everyone? (approx timescale)

It will be in the next OSMC update, so before the end of April.
There are a few other other improvements I’d like to get in this update window.

Sam

I completed the update from the staging repository and I still have banding (which began after the March update). Can someone please confirm the EXACT steps needed just so I can be sure I’m doing this properly?

The exact steps are listed as above. Nothing further should be necessary. Could you run uname -a to confirm that you updated successfully, and can you confirm if you’ve ever updated rc.local to set 10-bit output manually?

Some logs via My OSMC will definitely give clues

Sam

I’m out for work whole week, hopefully there ll be such an update next weekend :slight_smile:

For me settings 444,10bit with rc.local is no option because I got 4K files with BT709 colourspace, like the kodi menu … only option for me is to set 444,10bit with every 4K file that has BT2020.

Any solution for that on the horizon?

Can someone post some proper instructions of how to do this temporary fix please, for example Sam’s instructions state “Edit the file /etc/apt/sources.list”…
How does one do this exactly. How do i a gain access to this file

I’m on windows and using putty to login the Vero,

Cheers