[TESTING] Bluetooth audio streaming (A2DP)


why do you ignore my error reports?


We don’t. But I don’t believe you’re using the official OSMC adapter. Other adapters are sometimes problematic. We know this but don’t have a solution.


sorry, your answer tells me the opposite. :frowning:
there is no error with my bt usb dongle.
it is not depended by the official OSMC adapter.

i have installed the last current osmc version + a2dp from 1st post
when bt usb dongle is plugged in, all is working fine.

when bt usb dongle is unplugged, the bt player service starts with an error.
and it is not possible to connect a wifi network.


these are my steps:
Rasp 2 or 3

  1. no osmc or other bt usb dongle plugged in
  2. new osmc system
  3. no osmc or other bt usb dongle plugged in
  4. install a2dp
  5. no osmc or other bt usb dongle plugged in
  6. disconnect and forget wifi connection
  7. no osmc or other bt usb dongle plugged in
  8. restart system
  9. no osmc or other bt usb dongle plugged in
  10. error btplayer addon
  11. try to connect my wifi
  12. error osmc networking addon


Meanwhile I re-installed OSMC and enabled the IQaudIO Pi-DigiAMP+ after installing app-a2dp-osmc. “pactl list sinks” shows the IQaudIO Pi-DigiAMP+ and also a USB audio-interface when plugged-in, but they are always in “State: SUSPENDED”.

Anyone having an idea what’s going wrong?

Thanx for any hint! :slight_smile:


@sam_nazarko It seems KODI has no support for Pulseaudio in OSMC and ignores virtual ALSA devices which explains the weird behavior.

Please enable Pulseaudio support in KODI!


We don’t want to do that.
If we do that then you will have problems with passthrough.

Building Kodi without PA is intentional.


How is Bluetooth-audio supposed to work if Pulseaudio cannot access the ALSA devices?


PulseAudio runs independently of Kodi.

We want Pulse to access ALSA.
We don’t want Kodi to access Pulse.


I suggest to allow KODI to use ALSA devices of type plug/plughw instead of hardware devices only. If you create a /etc/asound.conf with
pcm.default type pulse ctl.default type pulse
users can switch KODI between direkt ALSA hardware access and Pulseaudio which means multiple audio streams can be mixed or switched between them.


It already does. Did you put dtparam=audio=off in config.txt as suggested?

Check your card config in /usr/share/alsa/cards.
If you have a PR, then it will be appreciated.



OSMC does this when I enable the IQaudIO Pi-DigiAMP+. As a result Pulseaudio finds the Pi-DigiAMP+ and a USB audio device when plugged in but no HDMI/Pi analogue anymore.

Maybe there is a misunderstanding. I want to stream via bluetooth from e.g. a phone to the RPi and use it as an amplifier. Does OSMC only allow to stream it’s audio playback to a bluetooth speaker/amplifier?


Those aren’t ALSA outputs off the top of my head, it’s handled by PiSinkAE.

What do you see sans Pulse?

There were some card config updates for JB/HifiBerry, but not iqAudio yet. I don’t think if this will resolve your issue.


Can you enable ALSA support in KODI? This would allow the user to switch between PiSinkAE and ALSA-devices. Creating an ALSA device of type pulse in /etc/asound.conf would then allow to switch the output of KODI between PiSinkAE devices and Pulseaudio. Both - KODI and Pulseaudio - have to have idle/suspending devices enabled to free the audio device for each other. This would allow the user to switch to a PiSinkAE-device for passthrough or to Pulseaudio for mixing audio streams (e.g. from bluetooth or a turntable connected to an USB/I²S-ADC). It would even be possible to use OSMC as a bluetooth hands-free equipment for cell phones with HFP-profile in Pulseaudio. :wink:


ALSA support is enabled in Kodi. ldd will show you linking against libasound2. If I remember correctly, you used to use a USB DAC with OSMC (which uses ALSA)

This is already possible.


Yes, I tried to use a multi-channel USB-DAC with the drawback of constant clicks in the audio. So I bought an AV-receiver. Hopefully the Flatmax Audio Injector Octo will bring reliable multi-channel input/output for the Raspberry. :wink:

My situation is that KODI shows only the PISinkAE devices and bluetooth output while Pulseaudio shows only the Pi-DigiAMP+ and a stereo USB-soundcard when connected with dtparam=audio=off. When I switch the /boot/config.txt to dtparam=audio=on Pulseaudio can see the analogue output of the RPi, too. I can’t get KODI to detect the ALSA device routing to Pulseaudio.


It doesn’t work like that.

PA forwards to an underlying ALSA sink, not the other way around.
BT -> ALSA was possible in an older BlueZ era, but not now.

PA is still experimental. We’re lucky if these scenarios work:

  • BT device to on-board outputs
  • Kodi to BT device.



The ALSA plug-in “pulse” creates an ALSA device and routes the audio-stream to Pulseaudio and vice-versa.


pcm.pulse {
type pulse
ctl.pulse {
type pulse



I configured this hundreds of times on Ubuntu machines but can’t get it to work with OSMC.



Okay – this isn’t something we can officially support at this time, so I understand that it’s not working as expected in OSMC.

But I don’t know why you’d make such modifications, so it is hard to advise. Given that you weren’t aware that OSMC already builds Kodi with ALSA support and supports BT -> DACs, I’d advise reverting any changes you’ve made and seeing if what you want to work works without any modifcation.

Unfortunately I don’t have any suggestion at this time. If you modify the audio stack in OSMC it’s not going to necessarily work as expected.



I’m new to OSMC. I have a Pi3 using built-in bluetooth audio and your a2dp instructions. There are occasional dropouts but the sound quality seems good. Would the dropout situation improve if I run movies and music from external usb hdd?