[TESTING] Bluetooth audio streaming (A2DP)


#801

Thanks for the effort ,now testing .

tested for 12 hr continues playing , no problem

1 time when reconect bleutooth speaker had a sad face, sorry no log file

setup : logitech ue mobile boombox on rasp3


#802

Hello,

1st: I have a Pi3 B+ since march and the first and only OS what i use is OSMC! I love this. Grat for the perfect job!

My problem is that i am not a geek and really new to linux/unix… so sometimes hard to understan the things :slight_smile:

So my problem is: i have installed A2DP for OSMC. i am able pair/connect the Pi with my JBL Charge 2+. But the proper sound output does not appear in Kodi settings…
There are the usual outputs and an ALSA but not the bluetooth streaming in the name.


#803

Provide logs so that we can check what might be wrong


#804

Logs: https://paste.osmc.tv/evaqakuyab


#805

one more question… current System is from jun or july…
What would be the steps if perform a clean install with latest osmc image?
Detail please because i am really noob… :frowning:


#806

Ok, your log file shows you should have Alsa: Playback/recording through the PulseAudio sound server this is the correct one to use even it doesn’t show Bluetooth in the name.

Why don’t you just update the system via MyOSMC?

Same as how you installed it first round. Means use installer from https://osmc.tv/download/ on your PC to write the latest image to the SD Card. You may want to make a backup before via MyOSMC.


#807

:grin: Sorry i meant: how could i install/setup bluetooth after fresh osmc install. And if i switch to external dongle, how can i disable the builtin?


#808

Just run sudo apt-get update and sudo apt-get install a2dp-app-osmc

Add dtoverlay=pi3-disable-bt to /boot/config.txt


#809

I am having the same problem. Installed a2dp yesterday to get my ps4 Bluetooth headphones to work wich it does but now on reboot get a distorted sound. Switching between pulseaudio and back to aml solves the issue.

This is on my Vero 4k+. Strangely on my raspberry pi 3 the headphones worked without having to install a2dp.


#810

You must have installed it before


#811

Well I’m pretty sure I didn’t because I did a completely fresh install on my raspberry just two weeks ago. I did upgrade to Leia to get Netflix running. And when I look in the audio settings on the Pi there is also no Pulsaudio available like I have now on the Vero. I must say that the headphones where kinda working on the Vero before installing a2dp but I just had sound in the left channel and on the Pi I have both left and right.


#812

It’s not possible for it to work without the a2dp package


#813

Hello All,

I’ve updated osmc, disabled internal BT and plugged in the dongle. Tested with 2 device:
1st, JBL Charge 2+ : the sound is a nightmare lol … as i see the JBL recognizes the Pi as a phone. There is a phone icon on it and it sounds like a phone talking… funny

2nd, Yamaha RX-381 AVR: sound is perfect, yeah! :smiley:

Questions 1: when i turn off the BT devices (jbl or yamaha) the output stays on ALSA. Sound comes from TV, but i thought it will switch back to PI:HDMI output. Is it ok?

Off question: is there an addon for kodi which switches the sound output to ALSA when i start music and than switches back to PI:HDMI when i start a movie?


#814

This is normal.

Search either this or the Kodi forum for “audio switching”


#815

Ah thank you! I have found: “Audio profiles” from Reggs.