[TESTING] Bluetooth audio streaming (A2DP)


Thanks for the effort ,now testing .

tested for 12 hr continues playing , no problem

1 time when reconect bleutooth speaker had a sad face, sorry no log file

setup : logitech ue mobile boombox on rasp3



1st: I have a Pi3 B+ since march and the first and only OS what i use is OSMC! I love this. Grat for the perfect job!

My problem is that i am not a geek and really new to linux/unix… so sometimes hard to understan the things :slight_smile:

So my problem is: i have installed A2DP for OSMC. i am able pair/connect the Pi with my JBL Charge 2+. But the proper sound output does not appear in Kodi settings…
There are the usual outputs and an ALSA but not the bluetooth streaming in the name.


Provide logs so that we can check what might be wrong


Logs: https://paste.osmc.tv/evaqakuyab


one more question… current System is from jun or july…
What would be the steps if perform a clean install with latest osmc image?
Detail please because i am really noob… :frowning:


Ok, your log file shows you should have Alsa: Playback/recording through the PulseAudio sound server this is the correct one to use even it doesn’t show Bluetooth in the name.

Why don’t you just update the system via MyOSMC?

Same as how you installed it first round. Means use installer from https://osmc.tv/download/ on your PC to write the latest image to the SD Card. You may want to make a backup before via MyOSMC.


:grin: Sorry i meant: how could i install/setup bluetooth after fresh osmc install. And if i switch to external dongle, how can i disable the builtin?


Just run sudo apt-get update and sudo apt-get install a2dp-app-osmc

Add dtoverlay=pi3-disable-bt to /boot/config.txt


I am having the same problem. Installed a2dp yesterday to get my ps4 Bluetooth headphones to work wich it does but now on reboot get a distorted sound. Switching between pulseaudio and back to aml solves the issue.

This is on my Vero 4k+. Strangely on my raspberry pi 3 the headphones worked without having to install a2dp.


You must have installed it before


Well I’m pretty sure I didn’t because I did a completely fresh install on my raspberry just two weeks ago. I did upgrade to Leia to get Netflix running. And when I look in the audio settings on the Pi there is also no Pulsaudio available like I have now on the Vero. I must say that the headphones where kinda working on the Vero before installing a2dp but I just had sound in the left channel and on the Pi I have both left and right.


It’s not possible for it to work without the a2dp package


Hello All,

I’ve updated osmc, disabled internal BT and plugged in the dongle. Tested with 2 device:
1st, JBL Charge 2+ : the sound is a nightmare lol … as i see the JBL recognizes the Pi as a phone. There is a phone icon on it and it sounds like a phone talking… funny

2nd, Yamaha RX-381 AVR: sound is perfect, yeah! :smiley:

Questions 1: when i turn off the BT devices (jbl or yamaha) the output stays on ALSA. Sound comes from TV, but i thought it will switch back to PI:HDMI output. Is it ok?

Off question: is there an addon for kodi which switches the sound output to ALSA when i start music and than switches back to PI:HDMI when i start a movie?


This is normal.

Search either this or the Kodi forum for “audio switching”


Ah thank you! I have found: “Audio profiles” from Reggs.


I installed the package and I tested it with a S7 phone it worked, I can send music stream from the phone to osm (raspberry pi). Then I tested it with bluedio headset. The headset is recognized by system and paired, but when I try to play some video o music from the system, it didn’t work, I change to alsa in sound options. The logs:




Headsets may create different audio sinks.
Check this thread


Thanks It works when I set device to a2dp_sin via pactl


Hi all, when trying to install the a2dp package I get the following error:
The following packages have unmet dependencies:
a2dp-app-osmc : Depends: pulseaudio but it is not going to be installed

Then upon installing pulse audio, same error with libsoxr0, then libgomp1, and finally
libgomp1 : Depends: gcc-6-base (= 6.3.0-18+deb9u1) but 6.4.0-11 is to be installed

However: gcc-6-base is already the newest version (6.4.0-11).

Any idea what it might be?


I think you have an issue with different repositories. You might at some time have installed packages out of the jessie-backports that you now have commented out.

Also what are the repositories you have defined in swupdate.openvpn.net.list