[TESTING] Bluetooth audio streaming (A2DP)


#821

I want to stream from my phone to a raspi 3 (using the integrated bluetooth of the raspi 3, without using an external dongle). The raspi runs osmc with confluence skin with up-to-date versions.

I could install successfully these commands:
sudo apt-get update
sudo apt-get install a2dp-app-osmc

What is the next step?
I’ve expected to find some new entry en confluence to configure/pair the bluetooth but I couldn’t. Are there such menus available? If yes, where?
Or should I configure the bluetooth using linux shell commands? If yes, how?

Thanks in advance!


#822

It’s in the MyOSMC addon

bluetoothctl


#823

Thanks @fzinken! I could pair my phone with “My Osmc” add-on!!!

I have still a problem: I can stream audio to the TV set but the sound doesn’t go to the analog audio output of the raspi. The audio output is properly configured, if I play music or videos, the audio goes to both, TV and audio output. My goal is to hear music without using the TV.

I took some time to read this thread and at least 15 persons have the same problem, but none of the answers helped me :frowning:

I’ve tried to configure ALSA settings as proposed by @Alistair_Richardson without success:
amixer -c 0 cset numid=3 1

Also setting setting hdmi_ignore_edid_audio=1 in /boot/config.txt does not make any effect (taken from ALSA audio through 3.5mm jack instead of HDMI)

The interesting thing is that when playing music over BT, changing any setting in audio output (only analog, only HDMI, both, alsa) makes no effect, the sound goes always to HDMI. Tests were done with these versions:

Kodi 17.6
Osmc 2018.12-1
a2dp-app-osmc 1.1.3


#824

Is A2DP working okay on the latest nightlies?

I can connect okay but as soon as I begin playback kodi insta-crashes and relaunches (although music still plays while this is happening).

Just want to check if I’m the only one experiencing this.

@sam_nazarko


#825

A2DP is not affected by Kodi (it can run with Kodi stopped); but it’s possible BTPlayer is causing an issue.

If you stop Kodi, does it work?
(sudo systemctl stop medicenter)


#826

Yes that works fine, no issues there. The crash occurs only when kodi is running immediately when playback starts from the audio source. I’ve tried re-pairing already.


#827

Can you post a debug log after the crash?

Sam