[TESTING] DVB improvements for Vero 4K

For some time, DVB support on Vero 4K hasn’t been in the shape that we want it to be. There are two reasons for this:

  • The Vero 4K kernel version is older than desired (a SoC vendor limitation currently).
  • The Vero 4K kernel is 64-bit (Aarch64), but the userland is 32-bit. This creates some issues with DVB FE ioctls

The most popular adapter on the Vero 4K is the OSMC branded DVB-T2 dongle. I’ve backported support for the second tuner which handles DVB-T2 and DVB-C in this commit.

This can be tested by running the following commands:

wget "https://api.openstack.ecloud.co.uk:7480/swift/v1/2321c64cd2674b9b81fe06c70cd687d3/osmc_tests/vero364-image-3.14.29-62-osmc.deb" -O vero3-image.deb
sudo dpkg -i vero3-image.deb

There is a second kernel available for testing. This uses the media_build tree to backport all DVB tuner support from Linux 4.9. Ideally, this is the approach we would like to use, but there seems to be issues with this, at least with the OSMC tuner. For those with a non OSMC tuner, or using a different DVB system, please try this kernel instead:

wget "https://api.openstack.ecloud.co.uk:7480/swift/v1/2321c64cd2674b9b81fe06c70cd687d3/osmc_tests/vero364-image-3.14.29-59-osmc.deb" -O vero3-image.deb
sudo dpkg -i vero3-image.deb

If you use the second kernel, I’d suggest stopping TVHeadend (sudo systemctl stop tvheadend) temporarily, and using this version of w_scan which has been patched against the new kernel headers which have been adjusted for 64-bit → 32-bit pointers.



great to see these improvements! I do have a non-OSMC tuner (a Terratec Cinnergy S2 USB Box, more details) which worked fined with a Raspberry Pi but not with the Vero 4k.

I’ll try your test build for this device soon, but I didn’t understand your last comment about the w_scanto be used. Does tvheadendonly fail to do the initial scan but should work afterwards with the scan results from your patched w_scan?


its good improvement i get work Silicon Labs Si2168 (DVB-T2 Geniatech Mygica T230 0572:c688) and HD channels dvb-t2

Which kernel did you use? What’s the output of uname -a?


1 Like

Linux osmc 3.14.29-59-osmc #1 SMP Sun Mar 4 05:08:41 UTC 2018 aarch64 GNU/Linux

Thanks – as suspected, this means you are using the media_build version.

First of all thanks for providing the beta kernels!

I’ve installed the first one, uname shows me “3.14.29-62-osmc” and lsmod indicates the kernel driver to be loaded. Running a scan in either TVH or with w_scan (TVH disabled) doesn’t recognize any (known) muxes.

Apart from that, dmesg doesn’t contain any reference to loading the firmware for the MN88473 and when I plug in the dongle after Vero has been booted it crashes.

Any hints on how I can fix / improve the initialization of the dongle? Does it make any difference which of the USB ports to be used?


Confirm working nicely with August T210 v2 0572:c688 with kernel version 2.

Edit: Shutdown, remove August stick, attach OSMC stick, restart vero, delete .hts/tvheadend/input/linuxdvb/adapters and restart TVH.

Now both realtek and panasonic tuners showing. Enable panasonic and try to watch TV, get TVH server unavailable then bad server response.

Disable panasonic, enable realtek and try to watch TV, get no free adapter.

Reboot. Still getting bad server response.

Restart TVH. Now can watch SD channels but with lots of picture breakup. Panasonic has disappeared from TVH webui.

Sam, Vero 4k here with official dongle and still no DVB-T2 adaptor showing.

Any information I can give you?

New OSMC DVB-T2 arrived today (delayed by snow)! Plugged in and set up. Did not show DVB-T2 adapter - only DVB-C and two DVB-T adapters. Ran code shows by @sam_nazarko. Rebooted and now tvheadend only shows one device - Realtek RTL2832 (DVB-T) #0 : DVB-T #0.

uname -a

Linux OSMCVero 3.14.29-62-osmc #1 SMP Mon Mar 5 17:00:37 UTC 2018 aarch64 GNU/Linux


Module                  Size  Used by
8021q                  18999  0
btsdio                  3186  0
bluetooth             251531  1 btsdio
6lowpan_iphc            6007  1 bluetooth
iptable_nat             2772  0
nf_conntrack_ipv4       7917  1
nf_defrag_ipv4          1441  1 nf_conntrack_ipv4
nf_nat_ipv4             3566  1 iptable_nat
nf_nat                 12609  2 nf_nat_ipv4,iptable_nat
nf_conntrack           55667  4 nf_nat,nf_nat_ipv4,iptable_nat,nf_conntrack_ipv4
iptable_filter          1478  0
dhd                   723320  0
cfg80211              356403  1 dhd
r820t                  17065  2
mn88473                 6154  1
dwc_otg               231839  0
dvb_usb_rtl28xxu       15864  8
rtl2830                 7242  1 dvb_usb_rtl28xxu
rtl2832                 8910  2 dvb_usb_rtl28xxu
dvb_usb_v2             13942  1 dvb_usb_rtl28xxu
wifi_dummy               798  0
mali                  196594  5
meson_ir                3801  0
ip_tables              16731  2 iptable_filter,iptable_nat
x_tables               18035  2 ip_tables,iptable_filter

All I can view are SD channels despite my local transmitter (Tacolneston) having quite a few HD ones.

Have I done something wrong or any suggestions on what to do next - apart from return the new bit of kit?

You will never get anything listed as ‘DVB-T2’. All adapters report as DVB-T even if they do T2. The OSMC stick has two DVB-T tuners - one does just DVB-T, the other DVB-T and DVB-T2. It’s the second one (panasonic) which is giving trouble.

This is a known issue, this thread is aimed at resolving this! Hopefully Sam will update us soon!

I only get one adaptor listed in TV headend, should I have 1 or 2 listed there?

There is only one adapter - one item plugged into USB but it only shows one DVB-T entry. It did show two Realtek and one Panasonic entry earlier before I ran sudo dpkg -i vero3-image.deb a second time. That could be my mistake!


Not really. TVH seems to be choking on the panasonic tuner. Not sure why it’s acting like it’s just not there.

1 Like

When it’s working properly (which it does on RPi BTW) you will see three adapters - panasonic DVB-C, panasonic DVB-T and realtek DVB-T.

1 Like

I can confirm what graham mentioned, at least when the dongle is already plugged in during boot time.

Did anyone successfully plug the OSMC dongle into an already running Vero 4K without making it crash?

Apart from not working hot-plug, the problem is mainly about not loading the required firmware to the dongle. According to previous experience this is necessary to actually receive something with the stick, even though it already shows up in TVH without having the firmware loaded.

Can’t reproduce that one here. What is the output of uname -a for you (so I know which version you have tried)?

We are still working on this. Firmware loads on tune here.


I have vero 4k with official dongle, only showing single receiver in TVHE.

Linux osmc 3.14.29-62-osmc #1 SMP Mon Mar 5 17:00:37 UTC 2018 aarch64 GNU/Linux

I’ll give it another try tomorrow morning, again using kernel version 3.14.29-62 as suggested.

Should it also work with w_scan for a quick check (with “service tvheadend stop”) or is it mandatory to trigger the scan process in TVH?

Are there any differences with respect to the two available USB ports with Vero?