[TESTING] Kodi 18 (Leia) builds for Raspberry Pi


#1451

Hi Tobias - is this really not working for you only since 17.8-375?
Because for me the last version to work was 17.8-369 (see my posts above). I would be curious to know if the versions in between really worked for you (and ofc why…)


#1452

I can confirm the last working version was 369 and I get the same log messages posted above. Does it follow that since the errors state a problem with stream 1001, it seems a problem with whatever codec is being used to decode the video - MPEG2VIDEO?

17:14:19.154 T:1420432112 DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - id: 1001, type MPEG2VIDEO, codec: 2
17:14:19.154 T:1420432112 DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - id: 1002, type AC3, codec: 86019
17:14:19.154 T:1420432112 DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - id: 1003, type AC3, codec: 86019


#1453

Same problem for me, tvheadand not working for videos, just radio and epg


#1454

I can confirm the last working version was 369 …

tvheadend does run recorded videos (matroska format).

Live TV (htsp) is broken (no sound, no video).


#1455

Think I found the issue.
PR15010 caused some issues and PR15020 was implemented to fix them.

PR’s were then merged but I still had a patch for 15010 which broke it again. I’ve now removed this so hopefully this fixes the issue in the next build (Won’t be 376 as this build is almost done)

Will be in 377.


#1456

17.8-376, 19 Dec 2018: Based off OSMC commit (10424a4da) and newclock5 (922b68c)

OSMC Skin Leia 17.9.3-27

  • Overlay patch

pvr.hts:

  • 4.4.5 - Fix buffer overflow in Logger::Log (PR:388, 1 commit, 4 files changed)

Includes latest addons: inputstream.adaptive (efd4b4f,
+3), inputstream.rtmp (ce7f559), peripheral.joystick (5429dc4), peripheral.xarcade (f09a0e7), pvr.argustv (83aa1e9), pvr.demo (964686d), pvr.dvblink (4ae42fe, +1), pvr.dvbviewer (cda813e), pvr.filmon (e850633), pvr.hdhomerun (a9d7309), pvr.hts(6a12442), pvr.iptvsimple (90a8d6f), pvr.mediaportal.tvserver (b17fdad), pvr.mythtv (d3a5af2, +3), pvr.nextpvr (ccdfd63), pvr.njoy (4467cac), pvr.octonet(203f800), pvr.pctv (b60b971), pvr.stalker (2245b0d, +1), pvr.teleboy (50689bd), pvr.vbox (6ed2f63), pvr.vdr.vnsi (cbb75ab), pvr.vuplus (1207082), pvr.wmc(81e2090), pvr.zattoo (4688f45), vfs.libarchive (6d39012), vfs.sftp (6749200), pvr.sledovanitv.cz


#1463

Any updates on the green artifacts when playing HEVC, or a workaround perhaps? Much appreciated!


#1464

Which version did you start having the problems on? If you go back to the previous version does it fix it?


#1465

I have had the problem since I upgraded to Leia; I’ve tried 370 and 374 and higher. Thanks


#1466

Ok, thought it was due to a recent change.
Is it happening with all movies? Can you upload a sample?


#1467

Sure: one minute sample here (mediainfo here).
And yes, it seems to happen with every HEVC file.


#1468

Link is not valid. I get a 404


#1469

My bad, just updated the link, please try again.


#1470

Cool, working. I’ll run a few tests.


#1471

17.8-378, 21 Dec 2018: Based off OSMC commit (c26b84e10) and newclock5 (922b68c)

OSMC Skin Leia 17.9.3-28

  • Remove hide preview art of TV show episodes option

OSMC

  • Fixup PR15010/15020 patch

Includes latest addons: inputstream.adaptive (efd4b4f,
+3), inputstream.rtmp (ce7f559), peripheral.joystick (5429dc4), peripheral.xarcade (f09a0e7), pvr.argustv (83aa1e9), pvr.demo (964686d), pvr.dvblink (4ae42fe, +1), pvr.dvbviewer (cda813e), pvr.filmon (e850633), pvr.hdhomerun (a9d7309), pvr.hts(6a12442), pvr.iptvsimple (90a8d6f), pvr.mediaportal.tvserver (b17fdad), pvr.mythtv (d3a5af2, +3), pvr.nextpvr (ccdfd63), pvr.njoy (4467cac), pvr.octonet(203f800), pvr.pctv (b60b971), pvr.stalker (2245b0d, +1), pvr.teleboy (50689bd), pvr.vbox (6ed2f63), pvr.vdr.vnsi (cbb75ab), pvr.vuplus (1207082), pvr.wmc(81e2090), pvr.zattoo (4688f45), vfs.libarchive (6d39012), vfs.sftp (6749200), pvr.sledovanitv.cz


#1472

I can replicate the issue on Leia on the rbp. Works fine on Krypton. Will recheck my patches to see if they are in sync.


#1473

Just tried to upgrade but version -377 not showing up.


#1474

There is no 377, see first post. Mirrors have sync’d now so 378 is available.


#1475

It took about 1h until it was synced. I will keep that in mind for next time.

I can confirm that the issue with Live TV got fixed.
Thx


#1476

Lovely, thanks for confirming.

Mirrors take up to an hour to sync. I think they sync on the hour.