[TESTING] Kodi 18 (Leia) builds for Raspberry Pi


#1527

i will try. I also installed some new add-ons, so it may be related to that, however the older add-ons also crash.
Its not a debuglog. but it shows something for now. Dont have time now to go and research the issue unfortunately. Basically when the buffer issues starts the rpi something seems to consume all the pi’s resources. Even connecting to SSH results in a timeout.

13:34:52.290 T:1407185648  NOTICE: Creating InputStream
13:34:52.897 T:1407185648  NOTICE: Creating Demuxer
13:34:53.638 T:1407185648  NOTICE: Opening stream: 0 source: 256
13:34:53.638 T:1407185648  NOTICE: Creating video codec with codec id: 27
13:34:53.651 T:1407185648  NOTICE: Creating video thread
13:34:53.651 T:910152432  NOTICE: running thread: video_thread
13:34:53.696 T:1407185648  NOTICE: Opening stream: 1 source: 256
13:34:53.696 T:1407185648  NOTICE: Finding audio codec for: 86056
13:34:53.698 T:1407185648  NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder eac3
13:34:53.698 T:1407185648  NOTICE: Creating audio thread
13:34:53.700 T:1407185648  NOTICE: Opening stream: 2 source: 256
13:34:53.701 T:1713369840  NOTICE: running thread: CVideoPlayerAudio::Process()
13:34:53.725 T:1713369840  NOTICE: Creating audio stream (codec id: 86056, channels: 6, sample rate: 48000, no pass-through)
13:34:53.941 T:1917595648  NOTICE: Display resolution ADJUST : 1920x1080 (1920x1080) @ 23.98 - Full Screen (54) (weight: 0.000)
13:34:53.959 T:1917595648  NOTICE: VideoPlayer: OnLostDisplay received
13:34:54.177 T:1917595648  NOTICE: VideoPlayer: OnResetDisplay received
13:34:54.210 T:1917595648 WARNING: OnMessage: Suspiciously long time to handle GUI_MSG_PLAYBACK_STARTED (1.91s)
13:34:56.044 T:1688204016  NOTICE: metahandler: Initializing MetaHandlers version: 3.0.3
13:34:56.066 T:1688204016 WARNING: CAddonSettings[script.module.metahandler]: failed to parse old setting definition for "db_port" of type "integer"
13:34:56.078 T:1688204016 WARNING: Previous line repeats 1 times.
13:34:56.078 T:1688204016  NOTICE: metahandler: Loading sqlite3 as DB engine version: 3.21.0
13:34:56.089 T:1688204016  NOTICE: metahandler: No SQLite rows requiring update
13:51:13.000 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
13:51:18.965 T:1713369840   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
13:51:22.741 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
13:51:27.162 T:1713369840   ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
13:51:29.624 T:1888482032 WARNING: ActiveAE - large audio sync error: -16110.281291
13:51:32.210 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
13:51:35.694 T:1888482032 WARNING: ActiveAE - large audio sync error: -24689.514569
13:51:36.953 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
13:51:42.301 T:1888482032 WARNING: Previous line repeats 2 times.
13:51:42.301 T:1888482032 WARNING: ActiveAE - large audio sync error: -31443.979723
13:51:42.502 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
13:51:48.139 T:1888482032 WARNING: Previous line repeats 68 times.
13:51:49.544 T:1888482032 WARNING: ActiveAE - large audio sync error: -36649.302377
13:51:52.966 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
        13:52:07.706 T:1888482032 WARNING: Previous line repeats 1 times.
13:52:08.150 T:1888482032 WARNING: ActiveAE - large audio sync error: -45811.801592
13:52:08.558 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
13:52:12.671 T:1888482032 WARNING: Previous line repeats 1 times.
13:52:16.185 T:1888482032 WARNING: ActiveAE - large audio sync error: -61371.175545
13:52:19.010 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
13:52:23.580 T:1888482032 WARNING: ActiveAE - large audio sync error: -70074.369187
13:52:29.672 T:910152432 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

#1528

So far Kodi at hasnt been crashing for me got loads of addons installed no slow loading times on RPI3B+ at all


#1529

17.8-397, 19 Jan 2019: Based off OSMC commit (02e96c01e4c) and newclock5 (40c4ab5b)

XBMC:

  • Fix artist discography for MySQL (PR:15277, 1 commit, 2 files changed)
  • [video][filesystem] Fix “XFILE::CFileFactory::CreateLoader - unsupported protocol(pvr)” logspam. (PR:15281, 1 commit, 2 files changed)

pvr.mythtv:

  • get the best candidate in EPG for the new timer (dffed32)
  • bump version 5.10.4 (5570ba2)

Includes latest addons: inputstream.adaptive (7688bb8, +1), inputstream.rtmp (ce7f559), peripheral.joystick (1f4225a), peripheral.xarcade (f09a0e7), pvr.argustv (83aa1e9), pvr.demo (964686d), pvr.dvblink (4ae42fe), pvr.dvbviewer(1ff63d4, +1), pvr.filmon (e850633), pvr.hdhomerun (a9d7309), pvr.hts (245df75, +4), pvr.iptvsimple (73feb2f, +3), pvr.mediaportal.tvserver (30c80ac, +1), pvr.mythtv (961d35e, +1), pvr.nextpvr (78c6633, +1), pvr.njoy (4467cac), pvr.octonet (203f800), pvr.pctv (b60b971), pvr.stalker (d0170c5), pvr.teleboy (1956113), pvr.vbox (ea20464), pvr.vdr.vnsi (cbb75ab), pvr.vuplus (bb6babc, +15), pvr.wmc (2697409), pvr.zattoo (ef6279f, +1), vfs.libarchive (6d39012), vfs.rar (0f56401), vfs.sftp (6749200)


#1530

Did it work?


#1531

Good news its not a Kodi Leia issue. Works on the latest LE, but still issues on the latest OSMC Leia build so it’s something OSMC specific.

Will recheck the patches. Otherwise @sam_nazarko might have an idea.


#1532

17.8-398, 20 Jan 2019: Based off OSMC commit (cfc2fb357d9) and newclock5 (40c4ab5b)

XBMC:

  • [lang][skin.estuary] updated language files from Transifex (b328d5e)
  • [lang][skin.estouchy] updated language files from Transifex (3aac935)

pvr.mediaportal.tvserver:

  • skin.estuary: fix background size and header label (b4e5bed)
  • skin.transparency: fix background, dialog size and position (3822d13)
  • skin.confluence: remove fallback media (fbb1ad3)
  • Add a separate fallback skin for showing the custom dialog when using an unsupported skin (4569c2d)
  • v3.5.16: (36409f5)
  • Fixed: TSReader RTSP playback (49ef7fa)

Additional commits/pull requests/changes not yet merged upstream:

  • Added: [pkg] PR:15284 (perma): Fix party mode slowness on MySQL

Includes latest addons: inputstream.adaptive (7688bb8, +1), inputstream.rtmp (ce7f559), peripheral.joystick (1f4225a), peripheral.xarcade (f09a0e7), pvr.argustv (83aa1e9), pvr.demo (964686d), pvr.dvblink (4ae42fe), pvr.dvbviewer(1ff63d4, +1), pvr.filmon (e850633), pvr.hdhomerun (a9d7309), pvr.hts (245df75, +4), pvr.iptvsimple (73feb2f, +3), pvr.mediaportal.tvserver (30c80ac, +1), pvr.mythtv (961d35e, +1), pvr.nextpvr (78c6633, +1), pvr.njoy (4467cac), pvr.octonet (203f800), pvr.pctv (b60b971), pvr.stalker (d0170c5), pvr.teleboy (1956113), pvr.vbox (ea20464), pvr.vdr.vnsi (cbb75ab), pvr.vuplus (bb6babc, +15), pvr.wmc (2697409), pvr.zattoo (ef6279f, +1), vfs.libarchive (6d39012), vfs.rar (0f56401), vfs.sftp (6749200)


#1533

Hy,

I can not search myosmc remotely in browser :frowning:


#1534

Is this a problem that just started after you installed Leia?
Is this a problem that just happened after a recent update?
Did you try to disable and enable the webinterface in Kodi?


#1535

yes with osmc 18 with the myosmc addon


#1536

Your explanations are not getting clearer.
What is the relation between the MyOSMC addon and a browser?
Please clearly explain your problem and provide debug enabled logs.


#1537

I can not add remotes to my osmc addon at remotes if you browse, you can not click anything

My osmc - remotes - browse can not click


#1538

Known issue, there is a work around, connect a mouse and hover the mouse over the first choice, then you can chose as you usually do.


#1539

As @joakim_s wrote its a known issue. But reading that issue out of your original message would have required some magic.


#1541

17.8-399, 22 Jan 2019: Based off OSMC commit (649bb4030) and newclock5 (40c4ab5b)

XBMC:

  • Fix party mode slowness on MySQL (PR:15284, 1 commit, 1 file changed)
  • Deprecate MySQL < 5.6, MariaDB < 5.5 (PR:15262, 2 commits, 1 file changed)
  • [videoplayer] dxva: fixed uhd hevc-main10 playback on xbox (PR:15300, 1 commit, 1 file changed)
  • [StringUtils] fix crash on addon install when using fmt 5.3 (PR:15305, 1 commit, 1 file changed)
  • Audiobook fixes (PR:15227, 5 commits, 6 files changed)

inputstream.adaptive:

  • Prepare license renewal / Allow partitial NAL unit encryption (22baed3)
  • Version bump 2.3.13 (9b944a5)

Includes latest addons: inputstream.adaptive (7688bb8, +1), inputstream.rtmp (ce7f559), peripheral.joystick (1f4225a), peripheral.xarcade (f09a0e7), pvr.argustv (83aa1e9), pvr.demo (964686d), pvr.dvblink (4ae42fe), pvr.dvbviewer(1ff63d4, +1), pvr.filmon (e850633), pvr.hdhomerun (a9d7309), pvr.hts (245df75, +4), pvr.iptvsimple (73feb2f, +3), pvr.mediaportal.tvserver (30c80ac, +1), pvr.mythtv (961d35e, +1), pvr.nextpvr (78c6633, +1), pvr.njoy (4467cac), pvr.octonet (203f800), pvr.pctv (b60b971), pvr.stalker (d0170c5), pvr.teleboy (1956113), pvr.vbox (ea20464), pvr.vdr.vnsi (cbb75ab), pvr.vuplus (bb6babc, +15), pvr.wmc (2697409), pvr.zattoo (ef6279f, +1), vfs.libarchive (6d39012), vfs.rar (0f56401), vfs.sftp (6749200)


#1542

I had bluetooth audio working fine for quite a while but now (presumably after a recent update) I am unable to get audio out to my speaker. I have no problem pairing, there is just no sound.

I tried looking around and found that when I connect to the speaker I get the following in dmesg with the mac address of my speaker bluetooth:
[ 899.158019] input: 04:FE:A1:A3:9A:80 as /devices/virtual/input/input1

I also tried running pacmd and got the following message:
No PulseAudio daemon running, or not running as session daemon.

Can anyone point me in the right direction on this?


#1543

Suggest to upload logs so that we can help you.
Do you still have a2dp installed and have the Bluetooth audio sink choosen?


#1544

installing a2dp via sudo apt-get install a2dp-app-osmc did the trick.
I’m totally confused about what happened since bluetooth has been working for months until recently, but anyway it’s fixed. Thanks.


#1545

@gmc Great, the last update fixed an issue with speedtest-cli package, already. Many thx.

That was the error

root@osmc-pi3:~# apt-cache madison speedtest-cli
speedtest-cli |    1.0.0-1 | http://ftp.debian.org/debian stretch/main armhf Packages
root@osmc-pi3:~# speedtest-cli --csv
Traceback (most recent call last):
  File "/usr/bin/speedtest-cli", line 11, in <module>
    load_entry_point('speedtest-cli==1.0.0', 'console_scripts', 'speedtest-cli')()
  File "/usr/lib/python2.7/dist-packages/speedtest.py", line 1400, in main
    shell()
  File "/usr/lib/python2.7/dist-packages/speedtest.py", line 1390, in shell
    print_(results.csv(delimiter=args.csv_delimiter))
  File "/usr/lib/python2.7/dist-packages/speedtest.py", line 665, in csv
    data['upload']])
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 1: ordinal not in range(128)

Still have an issue with package smartmontools on Pi3B, I think this was working some time ago on my Pi3B. It works fine on the Vero4k platform with current staging.

root@osmc-pi3:~# apt-cache madison smartmontools
smartmontools | 6.5+svn4324-1 | http://ftp.debian.org/debian stretch/main armhf Packages
root@osmc-pi3:~# smartctl --scan
# scan_smart_devices: glob(3) aborted matching pattern /dev/discs/disc*

#1546

The updates to Kodi would not have fixed this. Where other debian packages upgraded when you did the last update?

For smartctl does this help:
https://www.smartmontools.org/ticket/748


#1547

@gmc Indeed, the issue moves with the external USB enclosure used when connecting it to other OSMC devices. Sorry for the bandwidth!

Addition towards the speetest-cli package:
jfyi: Last changes here were
https://paste.osmc.tv/avovodanel
https://paste.osmc.tv/anacatocah
Whatever it was, I’m glad to find that fixed, now.