[TESTING] Kodi v18 release builds


The next version of Kodi v18 (codename Leia) was released in January. Since then, we’ve been working on bringing this up for OSMC. There have been a number of technical challenges, but we now should have a release that is of the standard you would expect from us.

It would be good if users could test this before we release this as a stable update, currently tentatively scheduled for Easter Sunday, 2019-04-21T19:00:00Z.

Supported platforms

This release supports:

  • Vero 2 (late 2015)
  • Vero 4K (early 2017)
  • Vero 4K + (late 2018)
  • Raspberry Pi 0/1
  • Raspberry Pi 2/3

Support for Vero 1 has now been discontinued, as the platform has reached end of life status. We will continue to keep older images on the website available for download.

How to update

Updating from a nightly build

If you are currently running a test build of Kodi, please ensure that you have not moved updated beyond the gmc-18 repository. We anticipate Team Kodi to branch Kodi v18 soon and proceed with v19. If you have moved to the gmc-19 repository then you will not receive an update by following the instructions below.

Updating from a stable version of OSMC

If you’re running a stable version of OSMC, then you should be able to update from a compatible platform without issue. Please make sure that you system is up to date first by going to My OSMC → Updates and initiating an update check; installing any outstanding updates.

Updating via the command line

To install the update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main

Go to My OSMC → Updates again, and initiate an update check. Install the updates when prompted.

Tracking releases

There are outstanding issues, so we plan to push some further test builds over the coming days. You may wish to keep the modification to /etc/apt/sources.list, but we would recommend keeping this active until the final release is made available. When we do this, we’ll make a clear announcement on the forums and blog.

Known issues

Currently, we are aware of the following issues:

  • Suspend mode is not working as expected on Vero 4K / 4K +
  • Hotplugging does not work as expected on Vero 4K / 4K +. This means that turing on Vero before you turn on your display may result in a locked resolution until you reboot the device.
  • The system information page needs a cosmetic fix to display versioning

I’ll update this section as more issues are discovered.

Frequently asked questions

Q: I’ve installed the update and now I only have a black screen or a sad face loop, how do I fix this?
A: It’s possible that your Kodi userdata is causing an issue with the new version. The first recommendation would be to move it away and allow Kodi to generate a new userdata directory. This can be done by executing the following commands after accessing the command line:

sudo systemctl stop mediacenter
mv ~/.kodi ~/.kodi-backup
sudo systemctl start mediacenter

Before attempting this, you may wish to try a more conservative approach, and delete ‘Addons.db’ only, as reports from users suggest that add-on migration is the problem

Q: I only see a black screen / hang on migrating add-ons, what should I do?
A: If you encounter this problem and a consider amount of time (more than half an hour) has passed, you should log in to the system and execute the above instructions from the previous question.

Q: I am using a shared library? Has the database version changed?
A: Yes. You should check that your other Kodi clients are compatible with Kodi Leia before upgrading.

Q: Are add-ons supported by Kodi Krypton supported in Kodi Leia?
A: Most add-ons that worked in Kodi 17 (Krypton) should work without issue with the new version of Kodi.

Q: I can’t find my add-ons anymore
A: To ensure compatibility where possible, Kodi disables any non-official add-ons by default when a new major version is released. You should be able to enable them manually under Settings. Note that this does not necessarily mean they be compatible with the new version of Kodi.

Q: Will my current skin work with Kodi Leia?
A: The new version of Kodi has reworked the skinning system extensively, and as such, only a handful of skins are currently ready for Kodi Leia. You should check with the developer of the skin to see if there is a Leia compatible version available

Q: My add-ons are not working, what can I do?
A: You should notify the developer of this add-on and ask them if there is a version compatible with the new version of Kodi. Unfortunately OSMC cannot do anything about this.

Q: How can I downgrade?
A: Unfortunately, downgrading is not trivial. However we will maintain Krypton images on our website for some time. If you discover a bug or issue, we are more interested in fixing it, as there will be users in a similar position, rather than having users downgrade.

Q: I don’t see all of my skin’s menus. What can I do to resolve this?
A: Please wait a few moments for the skin menus to be rebuilt. This may take a while to update if you have a number of add-ons on your system. If the issue persists, you should check that your skin is indeed compatible.

Q: CEC has stopped working, what can I do?
A: Power off your TV and device at the mains for 60 seconds, including your AV receiver if you have one. This usually resolves CEC issues.

Q: Why does the version show as Kodi Leia 18.2?
A: We have backported some official fixes for Kodi Leia since we anticipate it to be released shortly. To avoid confusion, we have retained the version bump. We will continue to update Kodi and deliver any fixes or improvements in future updates.

Q: My question is not answered and I am experiencing an issue, what can I do?
A: Please start a new forum post, with detailed information so that we can assist you with your problem.


  • 20/04/2019: added back HDMI hotplug detection for Vero 4K / 4K +; added support for game add-ons; fixed System Info screen; depend on libwidevine dependencies automatically.

  • 15/04/2019: initial release

Let me know how you get on




Coming from gmc-18 nightlies the update itself worked flawlessly. Removed the nightlies from /etc/apt/sources.list and added the stretch-devel from step 3. Tested on Vero 4k+.

When playing 720p content everything works fine. But most of the IPTV streams here are 576p letterbox which caused some headaches. On gmc-18 I had to switch to “Zoom” in OSD video menu to display these correctly. With this testing release I had to switch to “Stretch 16:9” to accomplish the same result (also works for 720p content as “Zoom” did before).

On gmc-18 I have only whitelisted 720p (which is the max IPTV resolution we get over here anyway) and whitelisting 576p caused faulty scaling on 576p letterbox movies. This is still the case with this testing release. Idea is to have my VP to do the scaling and have Kodi output anything at the most “native” resolution as possible which does not work atm due to this scaling issue.

Everything else seems to work like a charm for me.

I’m running the 17.8-433 build but I installed the gpg certificate earlier:

wget -qO - http://download.osmc.tv/dev/gmc-19/public/pubkey.asc | sudo apt-key add -

Is this why I cant find the update?
Any way to remote the certificate?

It’s not related to the certificate, whats the content of your /etc/apt/sources.list?

deb Index of /debian stretch main contrib non-free

deb Index of /debian stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free

deb http://apt.osmc.tv stretch main

http://apt.osmc.tv stretch-devel main

deb Index of /osmc/osmc/download/dev/gmc-18 gmc-18 main

You should remove http://download.osmc.tv/dev/gmc-18 gmc-18 main
And you need to add deb infront of http://apt.osmc.tv stretch-devel main

Tried that now. No updates available.

Did you run
sudo apt-get update
sudo apt-get dist-upgrade

Please provide URL of paste-log /etc/apt/sources.list

Sorry, how do I provide URL of : paste-log /etc/apt/sources.list?

Well if you execute that command you should get a URL been displayed.
Also can you confirm that you executed the other two commands?


You are missing the line deb http://apt.osmc.tv stretch-devel main

Yes, that is the right content (when you pasted it that line was not in there.
Also not sure what you just pressed that nano says `"/etc/apt/ " is a directory

Strange. The message "/etc/apt/ " is a directory comes up immediately without me pressing any keys.

Actually I assume you left a space in there e.g. sudo nano /etc/apt/ sources.list that would case that.You really have to be careful which files you edit and how. Not sure if this is the right path for you.


You were correct.
Not the right path? :joy:

Thanks for the help!

I wish to make a fresh install on the Vero 4K+ for testing, is there an image file available for that?