Tethering wired-to-wireless fails with "invalid password"

Hi Guys,
i finally can enable tethering wired-to-wireless by having now a wifi dongle with RT5370 chip.
I’m using a PI2 and OSMC 2016-08.
So i can enable the tethering mode via the OSMC Gui and also see this AP on my iPhone.
My Passcode is 12345678.
When i connect to the PI Wifi Network i will be asked for this Passcode, but when i type it the connection fails with “Invalid Password”.
Does this ring any bell? Which Log would be helpful here?

Thanks
Andreas

1 Like

Hello,
i did a fresh install of OSMC and get the exact same error when i try to connect. => Invalid Password

I captured this IW LIST log: http://paste.osmc.io/raw/fowuwafupa
and dmesg: http://paste.osmc.io/raw/adevuqipuf

Any help is much appreciated.

Thanks
Andreas

It’s me again.
I tried now to find out if connmanctl produces any logging or if there is any logging option. Unfortunately i just found a guide for openelec.

Can i produce a log with connman in osmc to get closer whats happening?
Is it possible that the error message with invalid password is misleading and the encryption or handshake is not correct or working?
I have really no idea anymore. I even tried to setup hostapd, but there are so many guides in the internet. I tested 3 and none worked :frowning: Also i don’t know if hostapd and connmanctl work on the same box.

Best Regards
Andreas

Sam,
good to hear from you.
I’m playing with this tethering / bridge also a lot currently.
I also bought the official OSMC 2.4ghz wifi dongle to get this working, cause i thought you will ship hardware supporting all features of osmc. But it’s not working cause it has a realtek chipset and what i have learnd so far that realtek and tethering in combination with connman is absolutely not working.
So i bought a ralink wifi dongle (rt5370) and finally could enable tethering without any error.
I also do see the created AP on my iPhone but can not connect. It’s just not accepting the passcode. But i’m 10000% sure to type in the correct passcode. See also my separate post. So we can discuss this then there.

The topic wired-to-wireless tethering seems to be a big dark space.
There is nothing in the official doc, there is not much very clear found in the forum. You said to may provide a list of wifi dongles fully working, i have not found this so far. Hostapd seems a solution for some users, but is not what i want on my osmc pi cause it seems to break with every new update.

I would much appreciate if TETHERING could be looked into and more documented and explained.
Just saying look for nl80211 is not the perfect way, cause there is coming so much back it will be just confusing.

Thanks
Andreas

First i have to apologize hijacking the other post. It was not my intention!
I got a step forward with this.
After reading a ton of articles etc. i decided to test out hostapd.
So i have followed this article:
https://www.raspberrypi.org/forums/viewtopic.php?t=74193&p=533206
instructions in post: “by jarrah31 » Mon Apr 14, 2014 7:37 pm”

Also i had to Blacklist wlan0 in the /etc/connmanctl.conf

Then I could see my AP but boom got the same error with the authentication “invalid password”.

I have modified the hostapd.conf to not use any password, like this:
interface=wlan0
driver=nl80211
ssid=hostapd1
hw_mode=g

Authentifizierungsmodus “Open System Authentication”

#auth_algs=1

akzeptiert nur WPA2-Verbindungen

#wpa=2

Pre-Shared-Key (PSK) im Klartext

#wpa_passphrase=secret_word
channel=7
ieee80211n=1

Doing this asked not longer for a password and did not show the lock sign for the SSID, but it gave me an error “can not connect to network”.

First adding this line in the hostapd.conf:
ht_capab=[GF][SMPS-STATIC][HT40+][HT40-][SHORT-GI-20][SHORT-GI-40][RX-STBC1][MAX-AMSDU-3839]
did the trick. I got the values from iw list which looks like this for my adapter:

HT Capability overrides:
* MCS: ff ff ff ff ff ff ff ff ff ff
* maximum A-MSDU length
* supported channel width
* short GI for 40 MHz
* max A-MPDU length exponent
* min MPDU start spacing

So i could now connect to the AP hosted by hostapd and i got a ip serverd by dnsmasq.
But, there seems to be always a but…
The reason why i’m doing this is cause i want to control kodi via the kodi app on the iphone.
And even when i am now sucessfully connected the app on the iphone can not locate the kodi server :frowning2:

So, Sam or any other, is there any debugging option for connman in omsc? I would really get this working with the inbuild features. With the given information above and how i got it working with hostapd can you imagine what might be the issue with connman?

I mean connman does show the AP as well, but saying invalid password. I bet if connman would have an option to disable the password i would get the same connection error as i got with hostapd. So something seems to be special to my RT5370 dongle to have these HT Capability options specified somewhere.

Thanks
Andreas

This is too hard to document. There are just too many dongles, and the chipsets inside sometimes change, so we don’t want to mislead someone.

Soon, I will add an nl80211 driver for this dongle. We didn’t advertise tethering yet though because it’s not ready yet.

We would expect ConnMan to handle DHCP reservations with tethering. Obviously if you cannot use nl80211 driver, that’s not possible. But I can’t offer much support with dnsmasq and I am not sure what else you may have changed on your system.

Pass -D to connmand and it will start in debugging mode. The ConnMan documentation is pretty good as well, and you can find it here: http://git.kernel.org/cgit/network/connman/connman.git/tree/doc

Not sure what that could signify, the best way to debug would be with WiFi on a PC and using Wireshark and pcap to get a dump of the connection attempt.

Thanks for the Feedback.
I will see what i get back with -D and come back here.

Hi Sam,
it took me bit to get this debug working.
Just for all others here is how i did it:

  • Boot OSMC
  • Via the shutdown menu i left OSMC and logged in to the console
  • sudo systemctl stop connman.service
  • sudo connmand -dn &> connman.log
  • via ALT+F2 logon to a second console
  • start tethering and reproduce the issue
  • After reproducing switch back to ALT+F1
  • Press STRG+C to quit logging

You can find the log here:
http://paste.osmc.io/raw/ahelulozex

I have not found anything looking weird. So maybe you as an expert see anything not working as expected.

So from my test with hostapd i know the dongle i have (RT5370) is working as an AP. Maybe connman is just missing a config parameter in the current implementation.

Btw. Do you plan updating version 1.30 to 1.33 in the next release?

Also can you let me know if the 5ghz dongle you guys offer does work with wired-to-wifi tethering out of the box? I know the 2,4 does not currently.

Regards
Andreas

Shouldn’t this be sudo connmand -dn &> connman.log?

No – newer versions of ConnMan have become quite problematic. There are also no fixes that would resolve this problem.

The RT5370 is missing an nl80211 driver which supports tethering. Hostapd tries to use the chipset’s implementation, but this is not always guaranteed to work.

Ahhhh this nl80211 will drive me crazy one day :slight_smile: As a linux starter this is really tough.

Can you recommend a wifi dongle which does fully support nl80211 ? Is the 5GHz you have in the webshop support tethering 100%? If yes i will order one, hopefully the last wifi dongle. I can open a own wifi dongle museum with all the hardware i have tested so far :smiley:

Sam,
please explain me one more thing. I found a lot of sites saying RT4370 does support nl80211 cause an “iw list” should produce this output to support the nl80211 api. And my RT5370 stick does exactly produce this output:

Supported interface modes:
* IBSS
* managed
* AP
* AP/VLAN
* WDS
* monitor
* mesh point
software interface modes (can always be added):
* AP/VLAN
* monitor
interface combinations are not supported

So i thought i am good to go.

Thanks. Changed. connmand is correct, not command

The 5Ghz WiFi dongle we sell doesn’t support Tethering yet. It wasn’t a huge priority as due to some issues with ConnMan (DNS proxying), tethering is on the whole broken, even for compatible dongles. It will be fixed in the future and we will add support (software) for our dongle.

Unfortunately just because support for a mode is advertised doesn’t mean it will work as expected. WiFi drivers seem to be targeted against old kernel versions and then never maintained. We just do the best we can do to support them, but the onus is primarily on the chipset vendors.

I have a shoe box with approximately 60 different WiFi dongles in them. Netgear UK are good enough to send us new WiFi adapters as they are released.

Cheers

Sam

Thanks Sam,

this sounds real difficult.
Can you name even one dongle having tested wired-to-wifi tethering support in osmc 2016-08?

Andreas

Maybe RTL8812AU chips, but as explained, they won’t work properly due to limitations in ConnMan itself, and I have not tested this chipset with hostapd.

I really want to stick with connman, i would avoid hostapd if possible. Hostapd was just a test.

Can you speculate about a timeframe for the nl80211 driver for you 5ghz dongle? If it would be 2016, i will go with that and can wait for it.

If there is no idea when, can you guide me how i can fully replace connman with hostapd then? If i have to go with hostapd i would then just do it right with your help.

Thanks
Andi

Nope – I’ve stopped giving timeframes for things as people otherwise hound you over keeping them to the letter :wink:

Sorry, I don’t know much about hostapd.