Took Sept upgrade lost HDD


I am running a RPi2. It has all been working just fine. Today I took the update and its seems to have lost the HDD. Not sure what to do. I tried a USB drive to see if it was an issue with my externally power USB drive. It couldnt see that either.

Not sure what to do



There was an issue with an early released update. Just try to update again and external drives should be fine again.

I have tired but it tells me there is no update. How can I force it to take the modified one?

Than your problem might be different. Upload logs to validate

Could you please point me to the instructions on how to get those for you.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I think I have copied the logs to the right place. Do I need to tell you something now so you know its mine?

Yes, the URL

Is that all you need?

Yes, I am currently not at my device so can not validate the versions but I believe someone else will pick it up soon

For some reason some packages on your system have not updated properly. Can you try the following via SSH:

sudo apt-get clean
sudo apt-get update
sudo apt-get -f dist-upgrade

If you get any errors please copy and paste them here. Assuming the commands go through without error type reboot then see if your external drive is working.

All worked fine but still no USB HDD

Can you please post a new full debug log then - the same way you did before so I can see what happened this time.

In both your logs the apt.log ends with
End-Date: 2017-10-02 14:51:36

So either you didn’t run the commands from @DBMandrake or your SD card is gone

Well spotted.

Assuming the commands were run then it’s likely that the SD card has failed and gone read only.

Often when SD cards fail they go into a kind of “read only” mode where it is impossible to write changes. If you create or modify a file the operating system will believe that the change was made (you won’t get an error saying it failed to write) but next time the file is read the original contents are still there.

Or if you create a file then reboot the file will be gone.

Coincidentally I’ve had two 8GB SD cards about 2 years old fail on me within a couple of weeks in exactly this way - one minute it is working fine, the next minute it is read only. That makes 3 cards now that I’ve had fail on me.

The way to test this theory is you need to make a configuration change or copy a file onto the SD card then reboot and see if the file is there - if it disappears and no changes that you make persist across a reboot your SD card has failed.

Rerunning your instructions then I will try adding a file

Log ended: 2017-10-02 14:51:36

Try creating a file and reboot