TP-Link Archer T2U and OSMC

Hi, I’m trying to get this wifi dongle to work with OSMC but no luck.

dmesg: https://paste.osmc.tv/xeqofihedo

I think there is more than one post on that dongle already

https://discourse.osmc.tv/search?q=archer%20T2U%20order:latest

I saw those posts but didn’t find any working solution, I will try again.

Which device are you using this on?

Raspberry Pi 2B+ and TP-Link Archer T2U

Ok, I am checking with @sam_nazarko if the adding of the ID (idVendor=148f, idProduct=761a) to the Mediatek 7610U driver actually has happen

Ok , thanks

So to verify if the driver works you could try this

unplug device

sudo modprobe mt7610u_sta
echo "148f 761a" | sudo tee /sys/module/mt7610u_sta/drivers/usb:rt2870/new_id

plug device

Ok, the option in My OSMC -> Network has showed up, but when I try to connect I’m getting connection failed.

//edit
but after rebooting osmc the option disappeard.

Well that is already a good sign. can you provide logs grab-logs -J -K

ok here: https://paste.osmc.tv/yumolavali

Thats normal, the changes we made are only temporary until reboot

Generally looks good, maybe try with connman on command line to connect. Also make sure all wifi profiles under /var/lib/connman/wifi* are removed before you try to connect.

Jan 17 16:12:38 osmc wpa_supplicant[368]: wlan0: Trying to associate with ac:64:62:6f:a9:8d (SSID='Livebox-A98C' freq=5540 MHz)
Jan 17 16:12:38 osmc wpa_supplicant[368]: wlan0: Association request to the driver failed

But maybe @sam_nazarko knows if the “request to the driver failed” indicates an incompatibility or not.

On fresh install and after applying this , it worked, now need to configure this to work on every boot and reboot
@fzinken can you help with this one ? :slight_smile:

Well I am not so sure how often you are restarting. Becuase the best would be just to wait for @sam_nazarko to include the VID’s into the next update.

But if you need to reboot frequently you can try to add the following to the end of /etc/rc.local (before exit 0):

modprobe mt7610u_sta
echo "148f 761a" > /sys/module/mt7610u_sta/drivers/usb:rt2870/new_id

I’m usually turning it of and after few days turn it on to watch something :slight_smile:, I think, I can wait for the update .

@sam_nazarko any ETA on update or info if you are able to include this VID’s ?

Not yet. We move to 4.14 for Pi soon; so it will need to be done after that. If you want, you can PR it for now; but focus is on the new kernel at the moment.

Sam

what PR means?
Ok, I will for now try @fzinken suggestion to add to /etc/rc.local ( I think , I solved the problem with rc.local :slight_smile: )

Push Request, means a fix of the problem in Form of a patch against the kernel driver.

I’d also like to push request this. Don’t know the correct procedure so I’ll just leave a comment. @fzinken 's solution worked as a temporary fix though! Thanks :slight_smile: