Trailers in Kodi

Hello all,
I’m running Kodi 16.1 on an OSMC build from a raspi 3
I’m having some issues in finding the “watch trailer” option
i’m pretty sure that I used to be able to click on the movie info and it would have a “trailer” button which would launch Youtube
But recently the button has disappeared.
I’ve tried to find out if an add-on crashed but can’t figure it out.
Anybody having the same issue?

You don’t say which skin you’re using, but the default Confluence skin uses the boolean condition ‘!String.IsEmpty(ListItem.Trailer)’ - and the OSMC skin the equivalent ‘!IsEmpty(ListItem.Trailer)’ - to decide whether to display the play trailer button, which is to say it will display it if a trailer was scraped when adding the media to the library.

As such it sounds most likely that a trailer wasn’t found for the media items when the item was scraped into the library. This therefore doesn’t sound like an OSMC issue, and so you may find you are able to get better support on the official Kodi forums.

Are these trailers for files that you have locally or from some addon?

Sorry for late reply,
the arrival of my baby girl has kept me away from Kodi for a while :wink:

The trailers are for some movies downloaded to my hard drive and catalgued into Kodi.
I remember a feature where when I pressed ‘i’ for info, I could choose to press Trailer and it would launch the youtube stream of the trailer ( so not a downloaded trailer)
Can’t seem to be able to do this anymore…

Do you have the YouTube addon installed and up to date? I suspect this will be a skin issue…

Yes it’s installed and is version 5.3.6
Do I need to be signed in to Youtube?

edit : and skin is Confluence

Have these titles been scraped into library? Have you pressed the i button and looked in the available options there?

Yes, they are all in the Movies section
and when I press the info it gives me :
Choose Art
Set my Rating

Might be worth addressing on the Kodi forums. I’m assuming that avail/non-avail of such trailers is determined during scrape. I don’t know why they wouldn’t be present. Works fine for me on OSMC skin.

I tried on OSMC skin and still not present. I’m assuming there must be an option somewhere but couldn’t find it.
I’ll try my luck on Kodi forums