Tranmission 403, uninstall and write properties

If you noticed Ive been having much trouble with transmission. I have spent a long time working on this and in my effort to fix the final bits I seem to have taken many steps back.

I now get the 403 error when trying to get into the web access.

Here are the key readouts that I think I need to provide for some help:

/etc/init.d/transmission-daemon - This has osmc:osmc and 777

/etc/transmission-daemon/settings.json - this has osmc:osmc and 777
whitelist: false (also tried with true)
whitelist ip - 192.168..
umask - 2 (I was having issues with files being written with transmission-daemon as owner not osmc)
incomplete and complete directories set

/lib/systemd/system/transmission-daemon.service - this has osmc:osmc and 777
Description=Transmission BitTorrent Daemon
ExecStart=/usr/bin/transmission-daemon -f --log-error
ExecReload=/bin/kill -s HUP $MAINPID

ps aux | grep transmission
osmc 1293 0.1 0.6 27128 4828 ? Ssl 23:44 0:00 /usr/bin/transmission-daemon -f --log-error

I have also tried reboot, restart and reload and finally tried to purge transmission but had a failure of uninstall. Is deluge or rtorrent any easier to use!?

Did you install Transmission via the App Store? This is the recommended method of installation

A purge should rid everything. Make sure you auto remove afterwards

I did install via the app store. I am trying to purge via the command line but hitting this error:

sudo apt-get purge transmission-daemon
Reading package lists… Error!
E: Splitting of file /var/lib/apt/lists/ftp.debian.org_debian_dists_jessie-updates_InRelease failed as it doesn’t contain all expected parts 0 1 0
E: The package lists or status file could not be parsed or opened.

I think you would do remove --purge

Run an apt-get update first

You can always dpkg-r it

Uninstall worked fine with the remove option thanks. Now when installing via app store I get error installing armv7-tranmission-app-osmc (2.8.4.-11) please repor this on the OSMC forum

Why are you trying to re-install if you just purged the App Store version?

transmission-daemon is only one part of Transmission.

You didn’t upload the APT log, which is the only needed log.

The easiest resolution is a fresh install.

I just reflashed my SD card with a half configured version in the end, but changes to the tranmission-daemon.service (user to osmc) and the umask values in the json seem to have landed me back in the same position.

I am going to reload now and change the umask value, leave the tranmission-daemon.service use as it is and run the following sudo usermod -a -G osmc debian-transmission

I take it that will run transmission as debian-transmission but add that user to the osmc group allowing it to act as osmc for files and operations that need osmc permissions.

I then just need to know, should my download directories be owned by debian-transmission or osmc?