Transcoding 96khz Dolby HD to stereo

I just came across a blu-ray, My Fair Lady 50th anniversary edition, with 96khz 7.1 audio. At first I thought something was wrong as I had no sound on one of my stereo TV’s. I then went to my multi-channel system and the sound was fine, with my receiver reporting a 96khz source via passthrough.

My question: are there settings for transcoding such a source to 48khz stereo, as most TV’s I think cannot handle a 96khz input? I just glanced through the menus and could not see anything, but it’s late and maybe I missed it. I could go back and create a secondary audio track but it would be nice if there was an option for handling this within OSMC.


What are your current audio settings?
Setting to PCM should do the trick

The problem TV has Kodi set to 2.0 channels, passthrough is disabled for all types. Sound is fine for all regular x.1 sources. Could the Vero be sending 96khz stereo for this title? Can’t offer a log just now but may be able to tomorrow.

I think the only way to do this is to select ‘fixed’ instead of ‘best match’ and 48kHz in the audio settings.

Thanks, the Fixed option worked. This is fine for me in a stereo-only system.

I noticed that with an OSMC Pi connected to an old Panasonic 2.1 speaker bar, that Best Match works on this title. I have all passthrough disabled and use MMAL for playback. So either the Pi has transcoded automatically to 48khz or the speaker bar supports 96khz stereo over HDMI? I can’t see how to confirm which one it might be. Would anyone know? Just curious!

I suspect the Pi has downsampled. What does the soundbar manual say?

The specs in the manual are very superficial, would be surprised if a 96k input was supported, so wondered if there is a way to confirm what the Pi is outputting. Just idle curiosity, happy to have sound from the Pi on this title without changing the settings.

I don’t know enough about Pis to know if there’s a way to find out without buying an expensive hdmi analyser.

Lets not get into a ‘is 96kHz better than 48kHz’ debate, though. :wink:

Pi does signal 96kHz PCM output via HDMI for more than 2.0 channels and even 192kHz for 2.0… But it might be that it actually does only output 48kHz. Who knows.

I just reconnected my spare V4K+ which has spent most of its short life in its box due to the CEC issues with my Panasonic speaker bar, and with Best Match I get no sound with the 96khz title. So I guess that means the speaker bar does not support 96khz (it would have been surprising if it did), and therefore the Pi is automatically downsampling to 48 when the Vero does not.

Good spot, thanks. Maybe Pi is feeding back audio caps to Kodi while Vero is not. We could look at improving that.

Could you post cat /sys/class/amhdmitx/amhdmitx/edid for vero attached to the soundbar?

Thanks for the further suggestion, but I get a no such file/directory message for that command.

OK, in case there was a typo in your suggestion, is this what you were looking for?

osmc@V_Kitchen:~$ sudo cat /sys/class/amhdmitx/amhdmitx0/edid
Rx Brand Name: MEI
Rx Product Name: 10SP_AMP
Manufacture Week: 29
Manufacture Year: 2000
Physical size(cm): 0 x 0
EDID Version: 1.3
EDID block number: 0x1
blk0 chksum: 0x18
Source Physical Address[a.b.c.d]:
YCC support 0x03, VIC (native 16):
ColorDeepSupport 0xb8 10/12/16/Y444 1/1/0/1
31 16 20 5 32 19 4 18 3 17 2 22 7 21 6 1 30 15 29 14
Audio {format, channel, freq, cce}
{1, 1, 0x07, 0x07}
{1, 7, 0x07, 0x07}
{2, 5, 0x07, 0x00}
{6, 5, 0x07, 0x00}
{7, 5, 0x1f, 0x00}
Speaker Allocation: 0x5f
Vendor: 0xc03
MaxTMDSClock1 190 MHz
ColorMetry: 0x3
RR_Cap: 0
LTE_340M_Scramble: 0
checkvalue: 0x18840000

Indeed. Thanks. Yes it confirms max 48kHz for PCM, AC-3 and AAC, 96kHz for DTS.

Thx. I wondered if the output gives any clue as to why the Vero does not play nicely with the soundbar via CEC?

No. CEC is a black art.