Transmission problem (permission error) - June '23 update

I am using OSMC on RPi2 for years with no major issues. Since the June update, Transmission has been behaving very wierdly.

On RPi boot I mount NAS folders as a media source, they are visible in /mnt and playing media from there works fine. Transmission also downloads stuff directly to these mounted folders. Before the June update this worked well for years. Now, most of the torrents start and when they download a couple of kbs or mbs they stop with the message “Error: Permission denied (…)”. This happens regularly, for most of the torrents (not all), which makes it particularly weird. Verifying local data does not help, deleting files and re-adding torrents neither.

Any ideas how to fix this?

We haven’t changed the Transmission client in some time. Perhaps there is another issue.

Are you maybe getting files from a different place than you recently did and that also happened at roughly the same time as when you upgraded? Is the difference between what does and doesn’t have success correspond to the length of the file path that is being saved? If so, then if you change the file path being used for a problematic torrent from…




Does the problem go away?

I tried shortening the folder names, it did not help. I also checked, some of the very long torrent names seem to work fine, most do not.

One more thing, which may be related to this. From the last update, Transmission crashed a couple of times. This never happened before. Rebooting RPi gets it working again.